Cannot Release Lock on SharePoint Online File

Silver Contributor

SharePoint thinks a user still has a lock on.  I can't adminsitratively do anything with the file online.  This has been going on for almost a day.


We've cleared cache, closed Excel on his computer, cleared out some local cashe directories, rebooted, etc.


Nothing is clearing up this lock.


All I want to do is delete the file at this point, and I can't even do that.


What are my options as a Global Admin?

96 Replies

Do you mean that the file is stuck on checked out state?

No checked out, "locked  by user"


Kinda like they opened it in Excel and still have it open so no one can else can open/save it.

Ugh, it self resolves itself shortly after posting on here...

I've seen a few reports of something that sounds like this this in our tenant this week, mostly from Mac users. The error message appears in the MS Upload center when the person is trying to save a file they've been editeing. It says "The file ... is locked for shared use by <the same user> [membership]. The files are not large, e.g., a 45 KB Word doc. Haven't found a cure, yet.




This has been a known "issue" of SharePoint for years...sometimes you get this "insane" problem of having files locked and nobody is actually editing them...just wait some times and SharePoint will release back to you :)

This is a very frustrating known issue in SP Online, and I can't really understand why we don't get an admin-tool (via PS, for example) to manage it.

My greatest concern is, what I've experienced many times, that the 10 minute timeframe MS promise for auto-unlock is simply not true and it took much-much longer to get access back to the file. Also the workaround they suggest here haven't ever worked for me. So my user (and admin) experience is that whenever this issue occurs, I have no other tools to fix it than waiting, and I have to tell the same to my users.

I now have a locked file (Word DOCX) that has remained locked for a few day. The funny thing is the user that locked it is me! I cannot edit, save, delete or anything. I have resorted to downloading an offline copy to do my work. Other complicating factors. MS Teams is overlayed on SharePoint, the MS Upload Center has run a few times and the cache is clear. Oh, and I have tried resolving this in both Teams and SharePoint itself. I remember this sort of problem back in the days of SP 2003 and SharePoint Designer was a big help in those days, sure do wish we still had that. I'll be watching this thread for solutions. ~ Doug



I just unlocked the file in question.  To reiterate from before, I received messages that somehow the system thought I was personally responsible for the lock out and I was unable to control this file.  As mentioned, I am in an working environment of SharePoint / Teams.  I had assumed that Teams was a collaboration tool layered on to SharePoint and that somehow SharePoint would have ultimate control over the file pemissions.  Apparently not!

The fix in my case was to confirm I was unable to make changes from within SharePoint and then go back to Teams.  Use the option "Open in Word" and not "Open in Word Online" or "Open in SharePoint".  Once I had it open in Word, I went to "File > Info > Manage Document", cycled through Check out and Check In successfully. and then saved.

What this tells me is that somehow the MS Teams application is also managing check outs.  One other possibility I am not able to confirm is that OneDrive for Business is somehow involved when storing the offline temproary file.

I still plan to watch this thread.  Best of luck, ~ Doug


I have the same problem on a wordfile. SP Online, Library has major versions enabled but no check-out required. I'm getting "the file is locked for shared use by....myself".


I opened the document in word browser and wrote some stuff. It saved and I navigated back, when I try to change a property in a choice column, I get that error message. 


I think it is a very misleading error message because I thought that co-authoring would also not work when I read "locked for shared use..". But co-authoring works, no problem. 


Solution for me is to open document in client and close it. Then I can change properties without any problems. 


Don't like this....






We have the same issue but in our case, its Sharepoint 2013, On-premise.

User has opened a doc in a library, made changes to word doc, tried to save and close.

The document is not able to be checked back in by domainname\user.

We then notice that the file is in th Upload Centre as "Upload failed" ..  and says check out for editing by the above user.

The impact is that other users have gon in and made changes after, so versioning is turned on which means the file has been overwritten. We resolve this by comparing the document with the current versions in SP.  

We have tried all of the usual fixes, like clearing the cache etc.,

We have also noticed that even though Microsoft say that the file is locked after closing for 10 mins, in one instance it took more than 30 minutes, but most cases not at all.




You sir have saved me from having a headache on a Monday!


Thank you.


Joseph Rothwell

perfect, worked like a champ!
I still have this issue just recently actually. It is locked by me, but I can manage to view it once in a while and close out - I do see other users on it as well (in Word client and Word Online). I'd like to just delete this file from our SharePoint Online document library altogether, but it keeps saying I can't because it's locked. :(

Any other solution you can think of is helpful. Thanks!
Same issues here with several users. Upload Center seems to be out of control. There is clearly something wrong. I found this old post Anyone here having experience with virus scanner software interfering?

I have same problem for Office 365 group site. in my case:

- Creating file online example 'WORD' and save from browser itself.

- Share file with someone within organization

- copy file to other folder in same site

and then I have use case to remove file.


I am getting error message the file is locked by other user and can't delete it.


Please let me know if someone got exact solution of this issues. 

Hello All


This was the solution that we came up with, that has now resolved all of our issues.


  1. Make sure the "webclient service" on client side is running 
  2. Find registry key: HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters on their machines.
  3. Find value: SupportLocking(if no, please add), set its value to 0, want to just disable lock feature.

This disables the locking feature via the registry and does not impact any other services.

I would suggest that you test it one 1 machine first to see if it resolves the issue prior to pushing it out to all production machines.





didn't work for me.


Upon further investigation, the 'file lock' happening for one user only not for others. I am administrator of Office 365 and not happening for me, also checked with one of my colleague who has contribute permission on site and no file lock for him.


another solution?  

Is the user in question using Microsoft Teams?


If so, this fixed the problem for me. 


"The fix in my case was to confirm I was unable to make changes from within SharePoint and then go back to Teams.  Use the option "Open in Word" and not "Open in Word Online" or "Open in SharePoint".  Once I had it open in Word, I went to "File > Info > Manage Document", cycled through Check out and Check In successfully. and then saved."

No - none of our users are on Microsoft Teams

Just adding more info on this, I am uploading file 'word document on SharePoint online using Office 365 group sites, Not Microsoft team.

1 best response

Accepted Solutions
best response confirmed by Alan Umanos (Microsoft)

Locks is a complex topic and technically a client or network issue. SharePoint supports co-authoring locks unless you have Check In/Out enabled on the library. Client side locks will occur if Office cannot negotiate a co-author lock falling back to an exclusive lock. As others have pointed out, the upload center can contribute to locking and is one of the first things you should check. You can trace the calls via Fiddler on the client.


This is the technical explanation from PSS:


When a user attempts to open an Office file hosted on SharePoint in the Office client, there is an expected set of network calls we should be seeing unless there is a problem. Once a user clicks that Office file to open in client, code on the SharePoint page and (if using Internet Explorer) the Office 365 browser addon sends a command to initialize the client application (Word, Excel, PowerPoint). Once the Office client application starts launching, Office will start a HTTP conversation with SharePoint. If the Office call is already authenticated, the Office will be returned the file content. However, if not already authenticated, which is usually expected to be the case, Office will negotiate for Authentication with SharePoint. This process happens through two networking calls called OPTIONS calls. The first OPTIONS call is anonymous and expected to be rejected by SharePoint as to establish what types of authentication SharePoint will accept. The second options call will include the requested authentication information to SharePoint. If SharePoint accepts the second options, call, it will return a METHOD call, identifying what network verbs can be used to communicate with it (OPTIONS, GET, LOCK, PROPFIND, and POST are all examples of verbs for this process). Once the verbs are established the Office client will make a POST network call that requests the metadata for the file, adds the user’s session lock state (coauthor lock or exclusive lock) and to request to open the file from the CellStorage web service in SharePoint. If the Office client has never accessed the document before, the entire document will be downloaded from SharePoint and cached in the Office Document Cache. If the Office client has opened the file before, then it is already cached and only the changes will be downloaded. At this point, the Office file will open in the Office client. This entire process happens between a few milliseconds to a few seconds.


View solution in original post