Add O365 Group Owner to Site Collection Administration List

Iron Contributor

I am struggling a little to find an answer for re-adding O365 group owner to site collection administration list.  Typically, when a new team site is created, O365 group owner is automatically added to the list of site collection administrator but when it is not listed, how can this be added back in?  If manually searching and adding [O365 group name] Owner, it is not listed but [O365 group name] Member is.  If [O365 group name] Member is added, everyone, including member/non-owners has site collection administration access.   So, any guidance in re-adding [O365 group name] owner back in would greatly be appreciated.

20 Replies

@Chris Ficek 


Find the GUID of the members Azure AD Group. Go into this location of your site and change the view to add the account info and also you can remove the filter to display hidden account.



Then take the GUID that end with the _o (This is the owner GUID of the group)

Something like c:0o.c|federateddirectoryclaimprovider|999999-9999-9999-aaaa-12212122_o


Take only this portion: 999999-9999-9999-aaaa-12212122_o


Go into the site collection admins and paste the GUID.

best response confirmed by Chris Ficek (Iron Contributor)

@Chris Ficekin the new SPO admin center, select the site, then look at the info panel, if the group is disconnected from the owner role, a message box will show up with a link to reconnect it.

Easier! Should have look at admin centers first. New features are coming every hour :)

@Martin Coupalvery true, and many are unannounced. I noticed that a while ago when I was trying to fix a problem caused by someone on my customers team that did not understand what they were doing with a script  (:

Please check the admin panel settings.

@Dean GrossThank you! 


Here is the feature Dean was referring to in reconnecting O365 group owners as site collection admins.




@Martin Coupal  I tried the method you mentioned and I was still experiencing issues where members still had site collection administration access.  The steps Dean mention and clicking on the message "add the group owners as admins" takes care of the issue.  I appreciate you offering your help as well!  Anything helps.  



Normally it is because the group.members were in site collection admin. This is misleading as the name they use for the members and the owner display the same in SharePoint. One way to be sure is to use the method I showed to display the account information (as both name are the same). But easy fix provided by Dean!

@Chris Ficek  I'm having the same issue as you but using @Dean Gross fix by adding the group owners as admin from the admin centre is again making the "Members" group show up under Site collection administrators, instead of "Owners" group.

Is that what you experienced as well?


This is weird that we can't add the "Owners" group again by simply searching for it!




@CharlotteDessertenne That is strange.  I have not experienced that issue as it should put the "Owners" group back in.  It could be a fluke.  Glad you caught that because we simply don't want to add "Members" group as a site collection admin.  Can you try removing them and re-add it using Dean's fix?  Do you get the same results as you did earlier?

@Chris Ficek Hi Chris,

I did it again, removing "XXX members" from Site collection administrator, going to the SharePoint admin centre, seeing the message about the owners not being admins for the site and clicking "Add the group owners as primary admins": 


Then it adds each owners' name (not the "XXX owners" group) in there, and the Site collection administrator shows up the "XXX members" group again.


Thanks for your help




That is strange -- I wondered if there is something clunking going on with the site.  Technically, it should re-add the Owners group back in.  Did the group get renamed, deleted or some?  


Can you create a test site, delete the Owners group from the site collection admins and then go to the SharePoint Admin Center and re-add the group.  Do you get the same results?  If not, then it might be an isolated case.  If it is not a hassle, could the site be recreated?

I am almost suspecting that this is a bug because if you try to add the Owners group in manually, it typically adds the Members group instead.  I even tried it with Sharegate, even though it listed the Owners group, it instead adds the Members group.  So I think it is a bug of some sort.

Here is a Microsoft article that talks about the groups based on the id.  for which I believe should've worked in the first place (as a back up).

@Chris Ficek You were right, this is a problem on this specific site.

I deleted the Owners group from site collection admins on a Test site, and then added them back up from admin center and it worked: the Owners group showed up again in site collection admins.


The site I have trouble with has been renamed indeed, so that might be why it's not working anymore... I unfortunately can't recreate it because it's already been quite challenging to get the users to this site.

I have even tried to use this trick [site address]/_layouts/15/permsetup.aspx to get my Owners group back, didn't work.

So I have created a security group with the owners names and added it as site collection admins. Do you see a big risk in the fact that the Owners group are not site collection admins anymore?


Thanks for your help


@Chris Ficek No idea what kind of bug hapened, but running the Get-SPOUser command shows that both groups (with or without _o at the end of GUID) gets the same display name of "XXX Members", whereas for other sites it shows "XXX Members" and "XXX Owners":



As you can see, the "XXX Members" group is part of SP Members and SP Owners, that's because I have tried forcing the GUID ending "_o" into the SP Owners group to see if it would at least get the right group as owner in the background, even with wrong display name, but unfortunately it picks the "XXX Members" one.


Is there a way to rename the group ending "_o" to "XXX Owners" in your mind? Or any sollution comes to your mind with this added info?

Your help is very much appreciated




@Rajkiran_Swain can you be more specific please? 

@CharlotteDessertenne I am not familiar in renaming the permission group name with PowerShell.  Sorry, I wished I could help you there.

@Chris Ficek No problem, Chris, thanks for trying! :)

Maybe someone passing by will have an idea, otherwise I'll just leave the site as is with the current set up which is not ideal but does work


@CharlotteDessertenne If you created and added another security group to the site collection admin, I think it should be fine.

I'm having the same issue - after renaming group, I can only add members to SCA and not the owners :(
I've tried Powershell (Set-SPOUser) and same problem. Is there a fix?

@OrangeJuiceJones, its been a few years since I've encountered this issue. Have you tried going to SharePoint Admin Center > Locate the active site and select it to get to the site settings. I am curious if there is a message that is prompt to add the group owners as admins is still.



1 best response

Accepted Solutions
best response confirmed by Chris Ficek (Iron Contributor)

@Chris Ficekin the new SPO admin center, select the site, then look at the info panel, if the group is disconnected from the owner role, a message box will show up with a link to reconnect it.

View solution in original post