SOLVED

Bulk Edit Not Working

Copper Contributor

I would like to bulk edit tasks, specifically the Task Calendar. 

 

I highlight multiple rows (2 or more), select Information -> Advanced -> Calendar and then pick a calendar, but no changes are made after clicking "OK".  This process used to work for making batch edits, but for some reason no longer makes the changes, regardless if it is  Calendar, Name, Dates, Durations, etc. 

 

I have closed the program. I have opened multiple files. Same result each time.

 

Please advise.

39 Replies
Kdekruif,
It works for me (Project 2019 Pro). What version of Project are you using?
John
I am using Professional 2019.
The bulk edit feature was working, but (2) weeks ago I opened Project to edit a schedule and now the bulk edit doesn't change my calendar. I have no idea what happened to cause it to stop working.
Kdekruif,
Try this. Save the file as XML. Then re-open the XML file in Project. Note, you will lose any custom formatting with this process. This process is the first order go to for clearing file bloat or corruption.

If it does not help, create a new project with just a few tasks and try the bulk edit on the Task Calendar field. Does that work?

John
John,

I saved the file as an XML. Closed the program. Then reopened the XML file. This process did not fix the problem.
I then opened a blank document, created a few tasks and tried a bulk edit. This did not work either.
Is there a setting that needs to change? Will I need to delete the app fully and reinstall a new version?

@Kdekruif 

The only option I thought might have an impact on this is the "edit directly in cell" found under, File > Options > Advanced group > Edit, but I tried turning that on and off and it didn't make any difference on my installation. But, if that option is off for you, you could try turning it on.

 

What is the version and build of your Project 2019 Pro? Mine is:

version 2308 (build 16731.20234 CTR)

 

Could you show us a screen shot of your selection that you are trying to bulk edit?

John

@John-project 

My "edit directly in cell" box is already checked. I did unclick/click it to see if it made a difference, but the end result is the same.

 

My version is 2308 (Build 16731.20234 CTR).

 

A screen shot is attached. It doesn't matter if I try to edit Task Name, Calendar, Duration, etc. No change is made after clicking "OK".

@Kdekruif 

 

It seems that the multitasking option is not possible, if there are several tasks scheduled in manually mode.

 

Regards.

Kdekruif,
Well now that's interesting. I'm not sure what I did previously but like you, that process doesn't work for me either.
However, There is another easy way to get there.
1. Make the multiple field selection
2. Select or enter a value in the active cell
3. Execute a "fill down" (cntl D)

This has nothing to do with whether tasks are auto or manually scheduled.

John

@Kdekruif 

 

I have done the same procedure of updating fields in Project Professional Multiple Task selection with version 2307, 2308 and 2309 (the latest update), and it does not work, independently of the Task mode (Manually or Auto).

 

Regards.

Kdekruif,
I wanted to see if bulk editing worked in previous version of Project and I found out it does. I created a simple test plan in Project 2010 and then attempted a bulk edit via Multiple Task Information. All tasks were updated as expected.

Since I don't use the bulk edit method you use, (I instead use the one I described), I can't verify if it worked in an earlier version of Project 2019 but it is possible that a recent update "krumped" the process and nobody, except yourself, noticed. I would not classify it as a bug but you might submit feedback through the feedback tab on Project, "I don't like something".

John
Thank you John and Ignacio for the information and assistance.
I thought I screwed something up in my settings/program, but my version must have updated "overnight" recently and the ability to bulk edit in that fashion was lost.
I will submit feedback and see if MS will restore the functionality through the Task Information window.
Kdekruif,
You're welcome and thanks for the feedback. It wouldn't be the first time an update created an unintentional glitch.
John
best response confirmed by Kdekruif (Copper Contributor)
Solution
All --

I have the same version of Microsoft Project that others are using. I just did an extensive test on the features in the Multiple Task Information dialog, and can confirm that NOTHING is working in this dialog. I tried changing the Duration for a block of tasks. No go. I tried changing the constraint type to As Soon as Possible to a block of tasks, each of which has a SNET constraint applied, and no go again. It is obvious that Microsoft has introduced a bug into Microsoft Project, and this bug NEEDS TO BE FIXED. I will report this bug to my contacts within Microsoft to see if they can get the fix moving. Thanks so much to all for reporting this.
Dale,
Thank you for backing up my request to MS. I would definitely like to have this feature restored (Although it was nice to learn a new version of doing bulk edits from John.)
Has anyone found a solution for this? I'm having the same issue after updating to Windows 11... Thanks!

@pfaria23

Solution? Yes, follow the procedure I outlined in my response on 25 September (above). As far as trying to use bulk editing via Task Information, I'm afraid you'll have to wait for a future update. The issue has been highlighted to Microsoft.

 

John

Thanks for the quick reply, John! It worked :)

If I may, I will just include another step in case someone else is trying to bulk edit the Task Calendars. The fill down will not work if you try to copy the calendar by selecting the
"Indicator" column. You need to add the column "Task Calendar" and follow the procedure John mentioned.
pfaria23,
Of course it works, it's the only method I've ever used :)
I thought the process was pretty obvious (i.e. a field can only be selected if it is displayed in the view) but your added step makes it more clear.
John

@Kdekruif 

I have the same issue.

To work around you could include new collum "Task Calendar" and change the calendar from here.

1 best response

Accepted Solutions
best response confirmed by Kdekruif (Copper Contributor)
Solution
All --

I have the same version of Microsoft Project that others are using. I just did an extensive test on the features in the Multiple Task Information dialog, and can confirm that NOTHING is working in this dialog. I tried changing the Duration for a block of tasks. No go. I tried changing the constraint type to As Soon as Possible to a block of tasks, each of which has a SNET constraint applied, and no go again. It is obvious that Microsoft has introduced a bug into Microsoft Project, and this bug NEEDS TO BE FIXED. I will report this bug to my contacts within Microsoft to see if they can get the fix moving. Thanks so much to all for reporting this.

View solution in original post