Team / Group Owner has to be a member as well to access Planner and add Planner Tab in Teams

Occasional Contributor

I created a new Microsoft Team via the Teams Admin Center. Unfortunately I was not able to Access the corresponding Planner Plan in Planner nor I was able to add a new Planner Plan as a tab in Microsoft Teams. I then found this article The solution is to add the Office 365 Group owner as a member as well. Than it worked. But actually this does not make sense to me. As a owner I should also be able to have access to the Planner Plan and configure a Planner tab in Teams. Why is this? Thanks for you feedback. Maybe this is a bug.

8 Replies
Unfortunately what you have experienced work in that way and it's by's not enough to be an Owner, the user needs also to be a member

Yes, but it is still a Bug in my opinion and should definitely not work like this by design.


  1. I am an Admin and create a  new Team in the Teams Admin Center where I define the owner of the group in the creation process
  2. The Team is created, but the owner I defined is just an owner and not an owner and a member in the same time
  3. The user as a owner now can't access the planner plan of the team, because he is not a member as well
  4. When I add the User also to the list of members in O365 Admin Center, than MS Teams thinks that this user is just a member, even though he is in both roles listed. The user now can't edit the Teams setting for his team anymore.
  5. I know have to define another owner for the group, remove the original owner from the team and add him again to the team as a member and make him an owner
  6. Now the user is correctly a owner and a member at the same time

Workaround is to create a team with an admin as a first owner, add all members and make some owners and than remove the admin from the team. That is very confusing and time consuming.

I just found out that when I add the user to the list of members via Azure AD than it works. Via O365 Admin Center -> Groups ... that it does not work.

I just had exactly same problem. One of the Team owners could not access a planner in his own Team.

I had to add this user to the Team members in Office 365 group. Problem solved!


Thanks for suggestion :)

@Michael Böhm , we see the EXACT same issue, where after the owner is made both an owner & a member in the group, the Teams application only sees them as a member.

The group & Teams admin center both still show the user as an owners, but they can no longer manage the team.

A 2nd team owner must make them an owner again in the Teams application to resolve it so they can add a Planner tab AND manage the Team.

Out of curiosity, was the tenant where you saw this behavior in the GCC? 

First, look at the date on my reply. Still at this point, nothing changed.
So what I have is that my project TaskList is on a Sharepoint site (so I can PowerBI it, as I can't do this with Planner).
There is a column called "Assigned To" where I can add a group or person that would be able to be selected.
Obviously the entire team should be able to be in the list of choices. So I select [TEAMS-GROUP] Members (as I can only select 1 group for that specific column).
Guess what? Owners do not show as they are not "Members".

So this "feature", "design", "intended way of working", or whatever you want to call, it is so stupid, completely illogical and moronic that it just baffles me that his is something Microsoft thinks is normal.

Yep, we're seeing the same thing. This is incredibly frustrating and unintuitive. It seems (although I'm not 100% sure) that when you create a team in the teams application, the creator is made a member, but when creating via the admin portal the creator is only made an owner, but not a member.
According to me this logic is correct as the admin is not the one who needs to be the member of the team as his role is just Teams creation (from admin portal) and delegation.