New UI changes rolling out in Planner

Bronze Contributor

Hi All,

Today Microsoft has started rolling out its refreshed UI in Planner which makes the use of Planner awesome! Below are the screenshots which explains the changes. Actions from Plans card viewActions from Plans card viewPlanner hubPlanner hubNew plan creationNew plan creationAttachmentsAttachmentsPlanner5.png

42 Replies
Awesome and great additions!!

Will the new UI support viewing plans that are created in Teams that aren't the primary plan for an Office 365 group?  Right now being able to change Plan wide settings such as notifications isn't possible with plans created from Teams, and was hoping the new UI might help brings those options around instead of just being able to view "My Tasks" from those Planners in the UI

Hi, both the two features you have mentioned are not available yet. This UI improvements is for better performance of planner for users with more number of tasks. 

It could just be my, but I think the new UI changes to Planner have messed up my ability to log in to the Planner Manager tool.  

Not even Problem with login. The biggest Problem since UI chance we lost the most description text in Planner Tasks. All empty. So Microsoft killed our Planner tasks.

Ticket open with MS Support but no solution yet.

Could anybody check if the same problem exists?

I'm seeing the changes now and no problems at all, I'm also seeing a new LogIn experience

Some planner task descriptions come back if we select (checkbox) display description in card. The biggest problem is, that we don't know one which tasks the description is lost and which task don't had a description. 


If anybody wanna see the problem i have made a video:

Hi @Robert Ryan, We are working for this change in Planner Manager tool and you can expect the next version very soon. 

Thank you Santhosh - your Planner Outlook add-in and Planner Manager desktop app are really useful; a shame this Microsoft update broke the login on the current version.

Same problem for us, opened a ticket with MSFT as well.

This is really bad...

Not sure if this is related or not, but now when managing a task from a planner created in Teams (so not a full task) I am unable to add an assignment as it just sits and spins as the following photo shows:




Even if I try to put the person's full email address or even full name it won't allow me to put in an assignment.  Also because these plans are not "FULL" plans, I have no way of seeing unassigned tasks to drag and drop assignments in the full UI.

One workaround till Microsoft fix this UI issue is to open the same plan in Teams and just everything works fine. Task description appears when Planner is opened from teamsTask description appears when Planner is opened from teams


Hi, I am unable to see this issue in Teams. I have tried with Old plan as well as new plan created from Teams. Both just works fine. May be you have to open ticket with Microsoft to get this resolved.

A New UI has improved the performance of Planner. I am so happy to see the Notifications control. Notification system in previuos UI was very irritating. 

Irritating change: When I now add a comment in a task, it does not keep my linebreaks/structure! Was able to make a list in the comments field previously, now it is gone! Give me back my linebreaks!
I love the new changes to the planner but two major changes that have gone backwards from the way I ran my planner is being able to see tasks by due date as seen in my picture. This is critical as we have switched over to every task is in our planner and its critical I can few the teams late items.

Additional item that would appear to be a chart glitch is even after I updated items from late to no longer late the chart still showed lates in it by each member. 

Looks like I'm able to add people again, so must not have been totally related, or fixed under the rug.

I'm having a lot of issues with the new design. Every 10 minutes or so, I get a "Your session has expired, please sign in again" message, and I have to refresh the page. Worse, the web app sometimes crashes completely and says that "the plan you're looking for is not here." In that case, refreshing doesn't help at all.

Screen Shot 2017-07-27 at 17.10.20.png

I have this specific issue with Chrome on macOS, but the "Your session has expired" notifications also appear on Safari and Firefox.

Planner used to work great before the update, am I the only one to have these issues?