Onedrive status icon folder stuck on Sync Pending in file explorer

Brass Contributor

Onedrive status icon folder stuck on Sync Pending in file explorer.

Tried to delete hidden temp files but icon doesn't change.


Any advice? Is this a know bug?

70 Replies
Stop -> start the sync !

Check the files that are failing! Try renaming or moving them! Then stop / start sync!

No files are failing, all files are synced, the folder is stuck on pending sync.
No errors shown? For how long have it been stuck?
Tried stopping the sync?
No errors, "one drive is up-to-date", all files are synced. Only some folders are showing "pending to sync" with nothing to sync? I guess Windows explorer bug?
Is already a few days like this. 95% of folders are showing the correct icon, some folders don't...
Try see if there is any hidden files or folder in those folders! Try also moving files to a new folder and delete that failing folder

Got the same "bug" in the new folder... synced all the files, but folder icon is stuck on pending to sync

You used same folder name? What is it?


Folder name is "Mobile", created a new folder name "Mobile 2"

Shouldn’t be an issue!
Sometimes just restarting the computer solves sync issues!
Otherwise delete the account and redo the configuration!
Try first to move files to a non error folder, delete the 2 folders with errors! Make sure everything is ok - then try creating a new folder - if it’s ok - then move the files back

Update: If I disable the option "Files on-demand" the problem disappaers.

What if you enable fod and disable it on the folder?
I've had this issue in the beginning with FoD, but it's gone away over time. Make sure you have the latest OneDrive client and Windows 10 build. Currently I am on OneDrive: 18.240.1202.0003 and Windows 10 1809
Updated to the latest Windows, Office and Onedrive version. No difference.
As @Chris Webb said, it might solve itself!
Have you tried anything from my latter posts?

Ok! Thanks!
For what I understand all of your files are synchronized and okay?
Yes all is synchronized, think its a explorer.exe issue. Tried all but unlink and reset onedrive :)