Hololens 2: odopen://launch is broken, and cannot sign into OneDrive UWP app with Azure work acct.

New Contributor

I have reset my Hololens 2 to factory default settings and then signed into my work account.

After downloading OneDrive from the Windows Store (UWP App), and opening the app, it says,
"The folder can't be displayed
Sorry, there was a problem. Please try again in a few minutes."

I have tried uninstall/reinstall OneDrive, clearining the app cache, signing in again, and completely resetting the Hololens 2.  None of this gets past the error above.  The account works fine with Android Onedrive and Windows OneDrive, but the Hololens2 UWP app is stuck with the above error.

 

However, if I sign into personal account on Hololens2 UWP OneDrive app, everything works fine.

Anyone using Hololens 2 also encountering issues signing into OneDrive for Business using the Windows Store OneDrive UWP app?

Last but not least, the OneDrive UWP app does not launch when I click on a URL: "odopen://launch" via the Hololens 2. This functionality is not built in yet.


Edit: I have also posed this question inside of the HoloDevelopers slack at https://holodevelopers.slack.com/archives/C1CQKRQM6/p1627500283409500  and will update my post if I find a solution to this

Edit 2: There is a workaround to this, open up the Microsoft Edge browser, point it to onedrive.live.com, sign in, and then install the website as a PWA.    However this does not immediately recognize the work account which is signed into the device, so this would have to be performed at an individual level instead of from a top down perspective. I hope that the OneDrive app gets fixed one day because it was definitely working in the past (as shown by my friend with Hololens2 using software version 10.0.19041.1154 on E1/E3 plans, his OneDrive app signs in perfectly to my accounts, but I am on OS version 21H1 OS 20348.1411 running the F3 license, and I have this error above).

5 Replies

@Raidenn Yup, having exactly the same problem on this, and 2 other units in our headoffice in the states. Pretty ridiculous issue to be having with such core features....

That is unfortunate, but thank you for confirming I am not the only one!

I first noticed the issue when trying to send a .JPG from Teams-->to Remote Assist in the Chat bubble.
Unfortunately the .JPG does not pop-up in the mixed reality space during Remote Assist (like .PDFs), and the alternative method of accessing the file through OneDrive UWP "Shared with me" is also inaccessible.

Theoretically, the .JPG should be accessible in OneDrive, but I just can't get past the azureAD sign-in for the UWP App.


"The folder can't be displayed
Sorry, there was a problem. Please try again in a few minutes."

I wonder if this is an issue with my account, or if this is an issue from the back-end. It's weird though that AzureAD OneDrive account works with all other apps except for the Hololens2 UWP app, which would indicate a bug rather than a license/account issue.

@Raidenn 

 

Has there been any movement on this? I am now seeing this. I factory reset and still the same issue.

Hi Vencent,

I have been told that OneDrive (UWP version) is no longer supported on HL2 for non-MSA accounts.

From this statement above, I gather that a Managed Hololens 2 cannot use OneDrive (UWP) and can only use OneDrive (PWA).

Definition of MSA Account versus Azure:
https://docs.microsoft.com/en-us/hololens/hololens-licenses-requirements
https://docs.microsoft.com/en-us/windows/security/identity-protection/access-control/microsoft-accou...

That is unfortunate because the OneDrive UWP was working perfectly before. Odd..

How could a MEM Administrator deploy OneDrive on 100-1000 Hololenses to automatically sign them into their OneDrive?  A PWA might not automatically recognize the account on the device just as the UWP app would. That is my dilemma

@Vincent_Guerrero 

Hi Vincent, I noticed today that there is a new OneDrive UWP app (v19.23.17.0) out in Windows Store. 
This version allows sign-in to work accounts and displays the files correctly.

However, the Share Menu functionality is yet to be implemented, as the user currently lacks the option to "Share" from the Photos app and then send via OneDrive to a friend.   
Edit: A workaround for this is to open OneDrive UWP, click "Upload">"Files" and then upload the picture, then use the Share option from within the OneDrive UWP app.   

This is good news to see it is improving!   The new version automatically signs into work account, which can save intune admin lots of hassle! :)