SOLVED

Cannot delete shared files

New Contributor

I have shared a folder with hundreds of photos with two people and given them edit rights. Neither one of them has the option to "delete" photos (our goal is to mutually cull hundreds of photos down to a few dozen for our web site). No "delete" option appears at the top bar when selecting individual or several photos at once. Is this function not available using "Share?"

See attached screen grabs from one of the people I Shared the folder with.

Help appreciated. Thanks!

4 Replies
best response confirmed by Bob_Lamond (New Contributor)
Solution

You seem to be using "anonymous/anyone" type of link, Deleting items is indeed not available for such links, even if you selected "edit" when creating it. 

@Vasil Michev thanks for your reply. I have tried both ways of sharing the folder; both anonymously and specifically via email address and the delete option does not appear either way to the people I have shared the folder with. At this point I’m assuming it’s just something that Microsoft has decided not to allow which is a little bit strange. Oh well!

@Bob_Lamond 

I have the same problem.

I also tried both ways of sharing the folder but the problem is still there.

Deleting was possible untill about 2 months ago, now I tried everything but I cannot find out what went wrong.

Did you have an answer in the meantime?

@Bob_Lamond I found a solution for this. If you send the link, people need to add the shared folder to their personal onedrive, which is an option once you select the folder.
After doing this the people should have full access to delete/edit items in the folder