User can't get Teams to work - error message

Copper Contributor

Have a user in a business environment in Peer to peer, getting the following error:
microsoft teams won't allow the user to sign in, getting error code caa70004


Teams is currently the free version, so finding support for this is next to impossible.   The app just wants to Restart, and goes no where but the error code.   Local users, not on O365, but the users account can log in on

Any help would be appreciated.   And no, have not just done the uninstall/re-install, yet.



31 Replies
Log out from client - clear the cache!

See here:

Start the client


@adam deltinger, hmm.   Tried that script, came up with a couple of errors, then seemed to run.  But the same issue.  So I'm thinking maybe the info didn't clear out.
I'm just going to see what happens with uninstalling and re-installing the app.


Hello,I met the same problem as you, did you resolve it by reinstalling the Teams?
best response confirmed by ThereseSolimeno (Microsoft)

@DHuttema We had this same issue today with teams installed on one of our machines, it turned out the TLS was switched off in Internet Explorer. Turning this back on resolved this issue for us.


  1. Open Internet Explorer.
  2. Go to the Tools menu.
  3. Select Internet Options.
  4. Select the Advanced tab and scroll down to the Security section.
  5. Check to see if you have TLS 1.1 enabled, TLS 1.2 enabled (checked).  If not, check the box to enable it.
  6. Select OK.
  7. Close Internet Explorer



It's not working for me either and I'm a office 365 user. Same messages as yours. TLS is not the problem.

It worked magically! Thanks



For me the problem was caused when I tried to login from my home PC.  The login page tried to redirected to our company sign on for authorisation against our firewall but I was already connected via a Cisco product.  So it displayed a blank page and then timed out with caa70004. I needed to disconnect from Cisco first, then log in to Teams and then our internal sign on page appeared successfully, then I could login to Teams. Then log back in to Cisco. This only happened when I changed my password.

@Rhys Allen Thanks! this worked :)

Post resetting my office password teams started showing the issue was receiving the same page 

"run into a issue" with error code caa70004.


Tried the following and it worked flawlessly, the inital mistake i was doing was that i was on VPN & company sign in page already.


>>> ensure you are not on any vPN or company related production connection, keep it on simple internet connectivity.

>>> clear the cache in all cache folders only

%AppData%\Microsoft\teams\application cache\cache


during the above ensure teams is not running, post clearing the cache start the teams on plain internet connectivity and then it shows the organisation sign in page post that it should work unless you have other underlying symptoms.

@DHuttema -  I saw this error, tried clearing cache, uninstalling, rebooting etc.  Nothing worked.  But we do use a web proxy agent, and when I disabled the agent, then Teams could sign in.  So I'd also check your web proxy and any agents that are filtering traffic on your network.  I need to follow up on why on this one PC the Teams sign-in was being block -- other PCs are configured the same way but don't have the problem.  Seems this is an error with many potential fixes - some cache-related, some network, etc


Reinstalling is the only thing that worked for me. I tried the other solutions first.


@DHuttemaafter disconnecting VPN I was able to login the teams. After that teams was working thru VPN as well.

@Rhys Allen thanks!  That worked!



¬¬¬Life SAVER¬¬¬


I just turned my BitDeffender Firewall OFF and everything worked like a charm.

I even had issues with "licencing" failures and all these went away.


Thanks again :)

Had same problem. just turned off vpn and started working. I hope it may work for someone.

@adam deltinger 

Script seems to be not working. Error below.



"teams_clear : The term 'teams_clear' is not recognized as the name of a cmdlet, function, script file, or operable prog
ram. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ teams_clear
+ ~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (teams_clear:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException"



Hi I cannot sign in my teams account ,

Error code - caa5004b,will you please help? Thank you !


@Rhys Allen  thank u man u solve my problem