Unable to switch to Teams-only mode


I tried to switch from Island mode to Teams-only mode. But the admin center is not accepting the setting. Why? 


2020-09-30 10_32_37-Teams upgrade - Microsoft Teams admin center – Opera.png


The screenshot shows one of my demo tenants. But I have the exact same issue with one of my prod. Tenants too.


6 Replies
Best Response confirmed by Robert K (Contributor)
Hi @Robert K

Could be an issue with the TAC. Try with Powershell

Let me know how you get on. Hope this answers your question

Best, Chris

@Christopher Hoard 


Thank you. This helped a lot.


I tried

Grant-CsTeamsUpgradePolicy -PolicyName UpgradeToTeams -Global

 and got

This organization cannot be upgraded to TeamsOnly at the tenant level because there is an on-premise deployment of Skype for  Business detected in 1 or more of it sip domains, xxxx.yyy. Users can be individually upgraded to TeamsOnly using either Move-CsUser (if the user has an on-premises Skype for Business account) or Grant-CsTeamsUpgradePolicy (if the user is homed in Skype for Business online).


Then I tried

$userlist = Get-CSOnlineUser
foreach($User in $userlist)
 Grant-CsTeamsUpgradePolicy -PolicyName UpgradeToTeams -Identity $User.SipAddress


And this worked for me. Case closed. ;)


@Robert K 

You need to make sure you donøt have any wildcard DNS records, as the Teams upgrade experience will try and do a DNS lookup for the SfB on-prem Autodiscover records.

If you can't remove the wildcard A or CNAME records, you will need to enter the Office 365 admin center and enable Skype For business services for your domain,s and get the DNS records for Skype for Business Online setup in DNS so the Teams upgrade experience can then determine that you are not using Skype for Business on-prem.

If you ask me, they should add a -Force switch to the PowerShell command ;)


@Michael MardahlAre you saying to remove the lyncdiscover and sip cnames? We have been using skype online only and the DNS entries look correct for our domain but we are using a wild card and are seeing this error. I don't want to remove the DNS entries if that isn't the fix. 


@kevinlause You don't need to remove the Wildcard. Just make sure, that the correct SIP-records are set, from the templates in the admin-panel in 365.


I had the same issue, where we couldn't switch to 'Teams Only':

- New tenant

- No prior SfB setup, hence no SIP-records in DNS.

- Wildcard on primary domain.


I added the SIP-records and I was then able to upgrade through the TAC.