Unable to connect to OneDrive. Please try uploading again. Teams error message when uploading photos

Copper Contributor

We use Teams to communicate within the company. About 50% of the time when I try to drag and drop or click the paperclip to send a needed photo or screenshot to the team, I get a message, "Unable to connect to OneDrive. Please try uploading again." None of the solutions I see online seems to solve the problem. I have Microsoft Teams Version (the currently latest version) on a Mac. I used Skype for years without any of these problems. I have a paid OneDrive account with plenty of storageScreen Shot 2022-06-02 at 4.30.46 PM.png

4 Replies

@LegalCEO 

Since the community has not yet responded to your post, you might want to seek assistance with other resources that are focused on tech support:

 

  • Ask your IT manager to open a support case or call Microsoft using the support line you were given.  Other options for business subscription admins are listed here:

Get support | Microsoft Docs

https://support.serviceshub.microsoft.com/supportforbusiness/create

@LegalCEO 

Go here...and READ...
https://docs.microsoft.com/en-us/microsoftteams/troubleshoot/files/cannot-upload-files-or-access-one...


...then run this...
https://aka.ms/TeamsUploadFilesInChat

...from there you will be able to determine why it is being blocked.

In MY case, it was because the end-user was NOT the owner of their own ONEDRIVE account.  The user was a returning employee, and another admin switched owner rights so the prior manager can have access to their files, rather than simply adding read privileges.

The above link helped me trace the issue and credit goes to Prathit Bhandari from the MS support team for helping me walk/talk through the issue!  :)

I'm getting the same error 

  • It's only in one Team I get this error. In every other team I'm a member of, uploading works perfectly. 
  • I don't get the error in the "general" channel, but the error occurs in two default channels (not private)
  • I'm also missing the "upload" function in the "Files" tab in these channels
  • I have tried in Teams Clasic and in New Teams, both online and app
  • I've created new channels in the same team, and the issue also occurs in those channels. 
  • I have checked the permissions to the file directory in SharePoint, and the member file permission is set to edit

@LegalCEO 

We just had the same issue. What we found is the Site Permissions for the Site Members was changed over to read-only. We were able to replicate this on a brand-new Team. As soon as we changed the site-level permissions for Members over to read-only, it broke the post/chat upload function. We also checked the channel folder permissions, which stayed as Edit... but the upload function seems to be controlled at the site-level. I haven't looked any further into this, but I'm guessing it may have to do with the M365 group permissions and what happens when the site-level permissions are changed.

Hope that helps!