Teams Won't Load

Copper Contributor

I cannot tell you how frustrated I am!!!

My Teams stopped loading - either my own account or using a link from another person.

I uninstalled it and reinstalled it but I just get a blue spinning wheel on the sign in page.

I tried the virtual assistant - who put in to chat with a person - who could only deal with "basic queries" - so they gave me a link to phone numbers WHICH took me back to the virtual assistant!!!

I am so fed up - can't believe that they are calling this a service.

Really hoping someone can help please.

48 Replies
best response confirmed by ChristianJBergstrom (MVP)
Hi, sorry to hear that. Business or Teams free account? You can always use teams on the web

As for the issue. Quit Teams (right click on the taskbar icon) and try resetting the desktop app by copy this: %appdata%\Microsoft\Teams and paste it via Start and hit enter. Delete all content in the location and start Teams again.

@ChristianJBergstrom thank you - finally got someone from Microsoft to help me 


Not sure what you mean, good to hear but I don't work for Microsoft if that's what you mean :)


MODERATOR EDIT:  @ChristianJBergstrom is a certified Microsoft MVP and expert in Teams, which means he has been recognized as an exceptional community leader and solution-provider. 

No I appreciate you trying to help - just glad it is resolved

I had the same issue. Out of nowhere Teams is not loading. It starts spinning for a few seconds but nothing happens. I see a task in the task manager but is not using any resources.  Ended up using the on-line version but would like to find out what the issue is with the Teams application. Does anyone know what causes the application not loading?

This sorted my problem too. Many thanks.
This fixed the issue for me, thank you!


Thanks for that tip. When I go to that folder (%appdata%\Microsoft\Teams) and try to delete the contents, it won't delete the files "teams-meeting-addin.log" and "teams-meeting-addin-loader.log". 

Associated with the add-in in Outlook. Make sure it’s shut down, but probably not necessary to remove either.
Thanks Christian - this solved my problem too...
That Worked like Magic! Thank you ChristianJBergstrom.
Microsoft should probably fix this bug that seems to be out there for some time.
YAY! That worked on my desktop computer! It still doesn't work well from m iPhone on a weak internet connection, but having it work on the computer is a BIG help! Thank you!


Can you help me by telling me where the folder is?  %appdata%\Microsoft\Teams

Sure, that's just a quicker way to get to the following location (and that's why you paste it via Start)

If you're using Mac this should do it ~/Library/Application Support/Microsoft/Teams
I was a little nervous since there were a lot of files in there, but worked like a charm! Thanks @ChristianJBergstrom
Same exact issue here and it worked for me too, thank you! Is it the large build up of files that causes the issue?

@S_hale Hey, glad it got sorted. Difficult to say exactly but the cache files are there and they mess things up sometimes. There's a more granular approach for clearing those files by being selective in that location. But it works by wiping them all too so that's why I suggested that in the very first post.


The more "official way" (which often is enough) is to simply sign out and quit Teams as those two things also release cached objects.

Thank you!
Yep, I tried logging out and logging back in, running updates, and nothing worked except your solution. Thanks again Christian!