Teams Personal Safe not working

Occasional Contributor



I have been trying to use the Safe function on Team personal for a couple of weeks on Android and cant get it to work.


Until an update earlier this week the app would crash each time I tried to access / set up Safe.  With the latest update I now receive an error message - suggesting to log out an try again. Screenshot attached, feedback has been submitted via the app.


I have tried this including a number of suggestions from the Office Support Twitter account but with out any luck.


I have tried 2 devices, uninstalling / reinstalling the Teams App, Logging out of all MSFT apps on the device etc.


Safe does work on an iOS device - but Android in my main device.


Any help would be appreciated. 


Thank you 

5 Replies

Hi @Andrew Reynolds ,


So I have had a look and as suspected the Safe makes use of a personal users OneDrive. However not the Personal Vault feature of OneDrive as I was expecting or at least not that I could see, but I digress.


Now in my instance, I had an extra battle on my hands to test this as the Personal account I currently had setup, bound to my mobile number was not matching the one OneDrive personal account you can have on a device.


So I tested and straight away it got into a muddle when clicking on the Safe app as it was then wanting to authenticate against one of my OneDrive for Business Accounts and when trying to suggest otherwise it got itself into what can only be described politely as a muddle.


So I went into my current personal account, disassociated my mobile from it. Then registered my other personal account for Teams Personal, the one that was added as a Personal OneDrive account on my device.


This time I was able to setup at the mobile number stage and also when clicking the Safe app it worked fine.


You can also see if OneDrive is working as expected within your Personal Teams Org by clicking on the Files tab and confirming that works?


So, sorry about the above but that was a long winded way of me saying what is the OneDrive situation for that Personal Teams account on your Android device?











Thank you for your reply and investigation.

As far as I can see the OneDrive accounts are correct, when I browse Files from within teams I see the files I would expect to see.  I also checked and only one personal OneDrive account used on the device.


I wonder if the issue stems from the fact that I used Safe first on an iOS device and the Android app is trying to run the setup process again?



@Andrew Reynolds 

Possibly, unfortunately I have no iOS device to put that theory to the test.






@henryarphillips365 I have previously sent feedback from with in the app so hopefully someone will pick up on that or see this thread and be able to give some advice. 

Thanks again for your help. 


@henryarphillips365 I deleted the safe from my iOS device and turn 'key management' to local, I was then able to setup safe on Android successfully.


So all seems to be solved for now


Thanks again for your help