Teams Live Event Creation Bug

Copper Contributor

I have been trying to create a Teams Live Event for 2 days now on multiple machines (Windows & Mac) and keep running into the same error.


When trying to create a Live Event after 12pm, with the finish time after this time, for example, 12:30pm - 1:30pm, I consistently get the error 


9 Replies
UPDATE: Now when trying to setup another Live Event for Thursday, I enter 6pm-7pm as the event times and it creates the event but is in the calendar as 6am - 7am!!! Frustrating! I need to send the attendee link out!

Hi @Nick-D ,


My company is having the same issue in Australia but only when using the local client on Windows.  When using MS Teams from the browser we do not have this issue. Have you had any luck resolving this?

Hey David - I'm also in Aus. I've just tried this work around and can confirm it works for me too! Thanks very much for your assistance, I was thinking I may have to use another platform to stream.

Hopefully this issue is resolved soon though!

UPDATE: Currently all live events entered after 12pm appear to create successfully but on closer inspection the times change from pm to am. So scheduling a live event for 6pm - 7pm actually creates an event for 6am - 7am.


The workaround using the web app is still the only solution to schedule live events after 12pm.

Hi @Nick-D   I escalated to our internal PM, who was unable to reproduce the bug (he thinks it's related to your specific time zone), so he's reached out to the worldwide team for further assistance.  Not the immediate answer you're looking for but if/when we can figure out a workaround we'll let you know.

Thanks - I have tested this on multiple machines, (Mac & Windows) our IT department has confirmed my time & date computer settings are correct so it's a weird issue indeed. I have also had colleagues test on their computers logged in with their own credentials and they received the same issue as well.
best response confirmed by ThereseSolimeno (Microsoft)

@Nick-D another work around for those that need to use the local client is to change their local PC's time settings to 24hr time.  While not ideal this has been the preferred resolution for some of my users.  

@Nick-D  Try changing your app language in Teams. Go to Settings>General>Change app language to English(Australia) if you are in Australia. It should fix this issue. Cheers

I hit the same bug today - the app language change fix from Baljinderbally worked. (Am in Australia - it was set to English United Kingdom)