Teams Custom App Icon Not displaying sometimes

%3CLINGO-SUB%20id%3D%22lingo-sub-1247823%22%20slang%3D%22en-US%22%3ETeams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1247823%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20everyone%2C%20having%20trouble%20with%20a%20custom%20teams%20app%20not%20displaying%20the%20app%20icon%20sometimes.%20Generally%20if%20you%20quit%20teams%20and%20re-open%20solves%20the%20issue%2C%20but%20this%20is%20not%20a%20good%20user%20experience.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%3A%3C%2FP%3E%3COL%3E%3CLI%3ECreated%20a%20custom%20Teams%20personal%20app%20and%20set%20custom%20icon%3C%2FLI%3E%3CLI%3EAutomatically%20pinned%20these%20apps%20to%20Microsoft%20teams%20for%20all%20users%3C%2FLI%3E%3C%2FOL%3E%3CP%3ESometimes%3A%3C%2FP%3E%3COL%3E%3CLI%3EApp%20Icon%20shows%20as%20blank%3CBR%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22NotAlex_1-1584994193060.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F178982i6D15E07060F6B42F%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22NotAlex_1-1584994193060.png%22%20alt%3D%22NotAlex_1-1584994193060.png%22%20%2F%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CLI%3EApp%20Icon%20shows%20correctly%3CBR%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22NotAlex_2-1584994230697.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F178983i28FDD69CE50F6BAD%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22NotAlex_2-1584994230697.png%22%20alt%3D%22NotAlex_2-1584994230697.png%22%20%2F%3E%3C%2FSPAN%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3EAs%20stated%20restarting%20Microsoft%20teams%20usually%20fixes%20the%20issue.%20Any%20help%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%3C%2FP%3E%3CP%3EAlex%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1247823%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1505048%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1505048%22%20slang%3D%22en-US%22%3EHi%2C%20I'm%20having%20this%20issue%20as%20well%20at%20several%20customer%20tenants.%20It%20gets%20really%20annoying%20when%20a%20customer%20has%205%20custom%20apps%20and%20they%20all%20show%20the%20obnoxious%20blank%20square%20icon...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1532751%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1532751%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1617874%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1617874%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20the%20same%20issue.%20Teams%20admin%20center%20says%20%22you%20have%20to%20add%20a%20license%20for%20showing%20icon%20for%20this%20custom%20app%22%3F%20I%20can't%20find%20anything%20about%20it%20and%20it%20worked%20earlier.%20Microsoft%3F%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1770342%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1770342%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20here.%20A%20statement%20from%20Microsoft%20would%20be%20great...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1787120%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1787120%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20here.%20Also%20the%20app%20does%20not%20start.%20It%20works%20in%20browser%20mode.%20And%20after%20re-adding%20it%20from%20the%20app%20store.%20These%20are%20workarounds%20but%20unluckily%20not%20a%20solution.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20experience%20this%20problem%20after%20updating%20the%20app%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2049020%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Custom%20App%20Icon%20Not%20displaying%20sometimes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2049020%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F833918%22%20target%3D%22_blank%22%3E%40M_Kha%3C%2FA%3E%26nbsp%3BWe%20have%20this%20same%20issue.%26nbsp%3B%20I've%20noticed%20that%20if%20I%20clear%20my%20teams%20cache%20the%20icons%20reappear%2C%20but%20if%20I%20switch%20between%20different%20Teams%20tenants%20(dev%2Ftest%2Fprod)%20the%20dotted%20outline%20issue%20reoccurs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20first%20noticed%20this%20issue%20after%20we%20updated%20the%20manifest%20after%20our%20initial%20release.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20heard%20of%20a%20resolution%20for%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi everyone, having trouble with a custom teams app not displaying the app icon sometimes. Generally if you quit teams and re-open solves the issue, but this is not a good user experience.  

 

I have:

  1. Created a custom Teams personal app and set custom icon
  2. Automatically pinned these apps to Microsoft teams for all users

Sometimes:

  1. App Icon shows as blank
    NotAlex_1-1584994193060.png

  2. App Icon shows correctly
    NotAlex_2-1584994230697.png

     

As stated restarting Microsoft teams usually fixes the issue. Any help appreciated.

 

Cheers

Alex

 

6 Replies
Hi, I'm having this issue as well at several customer tenants. It gets really annoying when a customer has 5 custom apps and they all show the obnoxious blank square icon...

I have the same problem.

We have the same issue. Teams admin center says "you have to add a license for showing icon for this custom app"? I can't find anything about it and it worked earlier. Microsoft?

 
 

 

Same here. A statement from Microsoft would be great...

Same here. Also the app does not start. It works in browser mode. And after re-adding it from the app store. These are workarounds but unluckily not a solution.

 

Do you experience this problem after updating the app?

@M_Kha We have this same issue.  I've noticed that if I clear my teams cache the icons reappear, but if I switch between different Teams tenants (dev/test/prod) the dotted outline issue reoccurs.

 

I first noticed this issue after we updated the manifest after our initial release.

 

Has anyone heard of a resolution for this issue?