Teams Call History Missing (Call Queues)

Copper Contributor



Settings up Teams to replace an on-prem PBX system and the setup is as follows. 

Auto Attendant -> Call Queue -> Teams Group


The basic call functionality is flawless, and I am very happy with the way it is working. The issue is at some point in the setup call history within the Teams channel stopped populating. The weird part is it WAS working. I can see calls early on in testing where it captured the calls coming in. Now it shows no new calls, and I cannot figure out why. This is the last issue I am having before fully launching the service and turning down the on-prem PBX. Please Help! 

3 Replies

Hi @anthony556,

To troubleshoot the issue with call history not populating in Teams:

  1. Check Call Queue Configuration: Ensure the call queue is properly set up and associated with the Teams group. Verify settings like call routing, voicemail, and team membership.

  2. Verify Permissions: Confirm your user account has the necessary permissions to view call history in Teams. Check if you have the correct admin or user role assigned.

  3. Review Logging Settings: In the Teams Admin Center, navigate to "Teams apps" > "Call queues" and review the logging settings. Enable any relevant options that might have been accidentally disabled.

  4. Restart Teams: Try restarting the Teams client application to refresh its connection and potentially resolve any temporary issues.

  5. Clear Teams Cache: Exit Teams, go to the %appdata%\Microsoft\Teams folder on your computer, and delete all files and folders within it (excluding the "Desktop" folder if present). Launch Teams again and see if call history starts populating.

    Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

    Kindest regards

    Leon Pavesic

1. Call Queue Config - This is a somewhat unclear direction. While I am very familiar with our on-prem PBX, I am not very familiar with Teams calling as it is new to me. I have reviewed the config and I do not see anything obvious to me that would impact this.

2. Permissions - I am a global admin and owner of the Teams groups and cannot see the history anymore. I do not believe there are any permissions elevated above these roles that can even be assigned. If there is something specific to check I would appreciate the info.

3. Logging Settings - The navigation you provided does not match what I see. Under Teams Apps I see Manage Apps / Permission Policies / Setup Policies / Customize Store. From what I can tell these are Teams add on applications and not what we are talking about here?

4. Application Restart - Tried numerous times including killing the application completely. The scope of impact is all users which makes me believe it is server side not individual user side.

5. Clear Cache - Tried this with no change. Again it appears server/config side not user side.


Hello Anthony, I'm having the same issue as you and trying to figure out what's stopping the CQ from allowing the handset to display the missed call. Have a few sites with the same setup and even when trying to compare, I can't find anything obvious.
Did you end up finding a fix?

When I call the handset number directly, the missed call is displayed. So, it's something to do with the CQ. 

Would love to know the fix.