Stuck in a login loop... I Have or I Don't Have is the question

Copper Contributor

I had setup a new Teams account successfully, added a team member, created a team, and then logged out... This was yesterday noon.

In the evening I tried to login back into my account and everything around me started revolving in circles...

Microsoft done not know if I have an account or i don't have an account.

Tried on Firefox, Chrome, Android App, Linux Desktop App... they are all driving me in crazy circles.


The world going round in pictures...

1. I try to login

Screenshot from 2020-02-09 01-40-34.png


2. It says I am not on Teams yet, and asks me to "Sign up"

Screenshot from 2020-02-09 01-40-51.png


3. Then I am taken to the Teams home page, where I click on "Sign up for free"

Screenshot from 2020-02-09 01-41-04.png

4. It says, I already have an account setup... So I click on "Sign in" 

Screenshot from 2020-02-09 01-41-20.png


5.  And asks me to open the app... and here I have tried both the options, web app, as well as desktop app... 

Screenshot from 2020-02-09 01-41-33.png


6.  And then it says that I am not on team...

Screenshot from 2020-02-09 01-41-46.png


If any one is interested I can add images for the second lap as well... (you are welcome on the ride)

This same happens on my Android phone as well (Samsung Note 9)

Now, I am not sure if I have got stuck in Groundhog Day, or have become the center of the universe.

But, any help would be greatly welcome.


P.S. Heck, I just realized that even the "Preview" option for the post on this very page isn't functioning...  ¯\_(ツ)_/¯

7 Replies

Hi @sumitanantwar!


I feel your pain, I've been there!


Open up your Control Panel > Credentials Manager > Windows Credentials > Check for all the credentials saved under Microsoft/Teams > Clear them up!


Try logging in again, you should be able to get in.


Lemme know how it goes.




Hi! The first few bulletpoints that comes to my mind.

1. Do you have a personal registered microsoft account with the same email as your organizational account. This can be a problem and you could try in this case to detach this personal account.
2. Have you been rearranging in your licenses lately?

@sheiksaad, Thank you for your reply. I haven't tried it on Windows yet but did it on Linux, Mac, and Android, and everywhere it has the same behavior, still not able to login!

@JBergqvistThank you for your reply.

I did not have a Microsoft account linked to this email, but it asked me to create one before setting up the Teams account.

Shall I detach it still?


No, I am not touching the licenses at all.

Strange problem and I hope it gets fixed soon :)

So first off.
This is an organisational O365 tenant with valid license for teams we are talking about here right? Since you are saying you were told to register a private account upon team creation, have you registered for teams when not logged in with your organisational credentials?
Is this a problem for just teams, Can you access other o365 services?

You should probably detach the private account. It may be problematic for the authentication flow knowing which account it should use.
Do that. Run in private mode and try to login once again with your org. Credentials.

Best of luck


I want to evaluate Teams, and so I am still on the Free version.

I am able to access other Office services without any issues, so it's Teams only issue.

I tried with my other emails as well, and it just does not want me to get in!

Tried Private Mode as well, still the same.

May be, Microsoft has come up with a No-Camera Facial recognition algorithm...

I have really wasted many hours trying to get a simple service working.

I had stopped using Microsoft services since I switched to Linux, and wanted to give them another chance. But, I think I better carry on with Slack.

@JBergqvist  I think iam facing this  issue can you please guide how to detach account of resolve this issue please?