Shared Channels - Can't share to a team on guest tenant

Brass Contributor

I'm trying to sahre a channel to an external team. I've selected the option to sahre to a team, entered the team owner's email and when they try to accept the invite on their tenant, they get a message saying they are not an owner of a Team, when they very much are. Owner of many teams in fact.








I can share with individual external users fine, the issue seems to be when sharing to external teams.



7 Replies
Hello, that's weird, I could share with team owners with no issues, but let's not forget this is still public preview, what happens if you try some other owner?
Same, I also tried to share with another org.

@drkmccy Can they try from a browser rather than the desktop client, just to rule our caching type errors.


This process is happening in their client in their tenant, so the client doesn't think they are Team Owners. I appreciate it's hard to find out for a remote tenants but is there anything unusual about how they provision new Teams, for example in the past it was possible to create Teams without the Owners also being Members which led to all sorts of issues.

@Steven Collier 

I tried all this in the web version of Teams. I'm the IT support for all these orgs so I can easily jump between the tenants. The accounts being used to share and accept are global admins and owners of several teams. I've also noticed that when I try to share the channel to an internal Team that I own, only one team shows up, when I'm in fact owner of several.... ?




@drkmccy Try getting another account to remove then re-add you to those Teams through the Teams client (not admin). See if that makes the Team then appear in the list. I'm still curious that there was this issue in the past where depending on how users were added they appeared in the list of owners but not members


Is there anything different about the Team that does show. Sensitivity labels ? Do they have existing B2B Collaboration guest users ?

@Steven Collier 


Tried removing and re-adding, that didnt make a difference. 

And no, the team is a brand new test team with nothing special about it.

I'll raise a support request with MS.....