SOLVED

Please help a newbie configure for Teams meeting recording

%3CLINGO-SUB%20id%3D%22lingo-sub-2046760%22%20slang%3D%22en-US%22%3EPlease%20help%20a%20newbie%20configure%20for%20Teams%20meeting%20recording%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2046760%22%20slang%3D%22en-US%22%3E%3CP%3EPlease%20be%20gentle%20with%20me%2C%20am%20a%20newbie%20to%20MS%20Teams%20but%20have%20a%20pressing%20need%20to%20record%20weekly%20video%20meetings%20for%20our%20community%20group%20trying%20to%20persuade%20a%20telecoms%20company%20to%20provide%20us%20with%20fibre%20rather%20then%20copper%20wire.%3CBR%20%2F%3EUp%20till%20now%20I%20have%20used%20Zoom%2C%20but%20uploading%20the%20125%20Mb%20MP4%20the%20our%20Teams%20can%20take%20up%20to%20six%20hours%20with%20our%200.8%20mbps%20upload%20speed%2C%20if%20it%20will%20upload%20at%20all.%20It%20seemed%20much%20simpler%20to%20use%20Teams%20for%20the%20meeting%2C%20which%20will%20put%20the%20recorded%20file%20where%20it%20needs%20to%20be%20BUT...%20Microsoft%20tell%20me%20that%20free%20Teams%20will%20not%20save%20the%20recording%3A%20it%20will%20start%20and%20stop%2C%20but%20then%20says%20%22cannot%20save%20to%20Stream%22.%3CBR%20%2F%3EI%20have%20now%20bought%20the%20cheapest%20365%20licence%2C%20and%20would%20like%20help%20on%20how%20I%20persuade%20Teams%20to%20save%20to%20OneDrive%20or%20Teams%20Files.%3CBR%20%2F%3EI%20am%20running%20Windows%2010%2C%20and%20have%20downloaded%20and%20installed%20PowerShell%207.%3C%2FP%3E%3CP%3ECan%20anyone%20offer%20me%20or%20point%20me%20to%20an%20Idiot's%20Guide%20to%20saving%20a%20Team%20meeting%20recording%20into%20Teams%20file%3F%20I%20had%20tried%20but%20failed%20on%20the%20first%20of%20several%20complicated%20configuration%20steps%20as%20illustrated%20below.%3C%2FP%3E%3CP%3ETIA%3C%2FP%3E%3CP%3EPaddy%20in%20Wales%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22powershell%20error%201.jpg%22%20style%3D%22width%3A%20652px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F245132iAE45FADC71BD6AC1%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22powershell%20error%201.jpg%22%20alt%3D%22powershell%20error%201.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2046760%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMeetings%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2046950%22%20slang%3D%22en-US%22%3ERe%3A%20Please%20help%20a%20newbie%20configure%20for%20Teams%20meeting%20recording%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2046950%22%20slang%3D%22en-US%22%3EFor%20recording%20and%20saving%20to%20Stream%20which%20is%20how%20its%20worked%20up%20until%20now%20will%20require%20a%20stream%20license%20applied%20to%20the%20person%20recording.%20What%20license%20did%20you%20buy%3F%20You%20can%20now%20also%20switch%20to%20the%20recording%20being%20saved%20in%20OneDrive%20or%20SharePoint%20by%20using%20Powershell.%20This%20will%20be%20a%20default%20and%20only%20behavior%20going%20forward!%20Read%20more%20here%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Ftmr-meeting-recording-change%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Ftmr-meeting-recording-change%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ERegarding%20your%20error%20I%E2%80%99d%20try%20to%20start%20powershell%20as%20an%20administrator%20and%20see%20if%20that%20helps%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E
Occasional Contributor

Please be gentle with me, am a newbie to MS Teams but have a pressing need to record weekly video meetings for our community group trying to persuade a telecoms company to provide us with fibre rather then copper wire.
Up till now I have used Zoom, but uploading the 125 Mb MP4 the our Teams can take up to six hours with our 0.8 mbps upload speed, if it will upload at all. It seemed much simpler to use Teams for the meeting, which will put the recorded file where it needs to be BUT... Microsoft tell me that free Teams will not save the recording: it will start and stop, but then says "cannot save to Stream".
I have now bought the cheapest 365 licence, and would like help on how I persuade Teams to save to OneDrive or Teams Files.
I am running Windows 10, and have downloaded and installed PowerShell 7.

Can anyone offer me or point me to an Idiot's Guide to saving a Team meeting recording into Teams file? I had tried but failed on the first of several complicated configuration steps as illustrated below.

TIA

Paddy in Walespowershell error 1.jpg

8 Replies
Best Response confirmed by ThereseSolimeno (Microsoft)
Solution
For recording and saving to Stream which is how its worked up until now will require a stream license applied to the person recording. What license did you buy? You can now also switch to the recording being saved in OneDrive or SharePoint by using Powershell. This will be a default and only behavior going forward! Read more here:

https://docs.microsoft.com/en-us/microsoftteams/tmr-meeting-recording-change

Regarding your error I’d try to start powershell as an administrator and see if that helps

Adam

@adam deltinger 

Thanks Adam, I bought a Microsoft 365 Business Basic. It seems to let me get to various configuration options but all a bit baffling! I don't for instance know how to find out if I have a Stream licence, which it seems I must have even though it is being superceded.

I will try running PowerShell as admin as you suggest and report back.

Thanks for taking the time to help!

Paddy

@adam deltinger 

Sadly, same via admin PowerShell (but at least I cracked how to copy text!) -- Paddy

 

PS C:\Windows\System32> Import-Module SkypeOnlineConnector
>> $sfbSession = New-CsOnlineSession
>> Import-PSSession $sfbSession
>>
Please enter the user principal name (ex. User@Domain.Com): (myname)@(mydomain).onmicrosoft.com
Get-CsOnlinePowerShellAccessToken: C:\Program Files\Common Files\Skype for Business Online\Modules\SkypeOnlineConnector\SkypeOnlineConnectorStartup.psm1:214
Line |
214 | $accessToken = Get-CsOnlinePowerShellAccessToken @params
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| One or more errors occurred. (Could not load type 'System.Security.Cryptography.SHA256Cng' from assembly 'System.Core, Version=4.0.0.0, Culture=neutral,
| PublicKeyToken=b77a5c561934e089'.)

If I remember correctly you should try to use an earlier version of powershell

@adam deltinger 

Cheers: I found I had 5.1 installed, and used that successfully! Onwards and upwards...

@adam deltinger 

OK, next line of the "https://docs.microsoft.com/en-gb/MicrosoftTeams/tmr-meeting-recording-change" script to change from Stream to OneDrive is

Set-CsTeamsMeetingPolicy -Identity Global -RecordingStorageMode "OneDriveForBusiness": this window results:

PowerShell Credentials.jpgAny idea what I supposed to enter as my password here? I changed Username to mine that I use to access tynyrhos.onmicrosoft.com and used my password, but got the following bad language back from PS:

New-PSSession : [admingb1.online.lync.com] Connecting to remote server admingb1.online.lync.com failed with the
following error message : The WinRM client cannot process the request. The authentication mechanism requested by the
client is not supported by the server or unencrypted traffic is disabled in the service configuration. Verify the
unencrypted traffic setting in the service configuration or specify one of the authentication mechanisms supported by
the server. To use Kerberos, specify the computer name as the remote destination. Also verify that the client
computer and the destination computer are joined to a domain. To use Basic, specify the computer name as the remote
destination, specify Basic authentication and provide user name and password. Possible authentication mechanisms
reported by server: For more information, see the about_Remote_Troubleshooting Help topic.
At C:\Users\Paddy\AppData\Local\Temp\tmp_1ekyj40c.dco\tmp_1ekyj40c.dco.psm1:136 char:17
+ & $script:NewPSSession `
+ ~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
gTransportException
+ FullyQualifiedErrorId : AccessDenied,PSSessionOpenFailed
Exception calling "GetSteppablePipeline" with "1" argument(s): "No session has been associated with this implicit
remoting module."
At C:\Users\Paddy\AppData\Local\Temp\tmp_1ekyj40c.dco\tmp_1ekyj40c.dco.psm1:50980 char:13
+ $steppablePipeline = $scriptCmd.GetSteppablePipeline($myI ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : RuntimeException

 

Wow! What can I try next?

 

Thanks

 

Paddy

@adam deltinger 

Adam, thank for your help on this, without which I could not have got this far! I think I can now close this request as I have got to the stage where I can record a Teams meeting to Stream, and can therefore migrate from Zoom.

In the end the main issue was that I had bought a new 365 Business Basic licence rather than upgrading my Free Teams. I cancelled the new licence, upgraded my Teams licence, and all the pieces of the jigsaw snicked nicely into place! I still have a couple of issues but will raise those in other threads if I connect solve them.

Thanks again!

Paddy in Wales, UK

Happy to hear!!

Adam