New error with Teams Call Queue Voicemail

Brass Contributor

Starting this week we have a Call Queue error.  This was working previously and we had reports from users saying that callers just had music and never had the option to leave a voicemail.  Opening the call queue, we spotted this error.  Please note - the Language is set to English in this same configuration screen.  Additionally the language is set for the Organization in the Office 365 Admin console.


We reached out to another company who is using Teams Voice and they stated they have this exact same error.  Any ideas here?  


call queue.png

18 Replies
I tried to reproduce, and it seems the message

"You must select a language for voicemail messages and play system prompts to the caller. "

it is always displayed, regardless if you have a language selected or not

What is the call timeout wait time you have configured?



I have the same issue, just started this morning. Callers are not getting forwarded to the voicemail anymore and the red message just appeared in the call queue settings.

@Andres, this is a strange one. The time is set to 2 minutes and more than 10 callers. Both of these conditions should in-act the voice mail but that does not happen. We don't have data that supports this claim, however, this is the assumption we are operating under. Based on feedback from callers via other methods, like in-person meetings, the caller hears the hold music 'forever' and due to this error the voicemail never goes into effect even if the conditions (2 minutes or more than 10 callers) are met

@tpeyton, good to know others see this as well but I'm sorry you have the same issue. I followed the support articles that seemed related but no resolution. The first was to ensure that Office365 had the correct Country, which is done. And that the language was selected in the Call Queue, which it is. I think something is going on here. I'm wondering if Microsoft launched some new feature during/part of the Ignite conference that had the side-effect?

@Andres Gorzelany here are the settings.  Before this week, there was no issue.   


Call Queue Language - 


And we shortened the time and number of callers to get to voicemail.  We are sure callers are exceeding those values and are not sent to voicemail



Hello Greg, thanks for the additional information,

I could confirm with someone from Microsoft that the "You must select a language..." is being displayed always regardless of the language selected or not and that is not intended, I also could reproduce that so I think you can ignore that for now...

Is this happening -every time- or just in some cases?

Can you call the billing call queue resource account voicemail manually to test if you get the vm?

is some issue reported at Service Health in the Admin portal for your tenant region?

@Andres Gorzelany, it seems, and I must run some tests today to be sure, that the callers never go to voicemail due to this issue. There is no description of this problem in the Service Health area related to this. We are in the middle of changing vendors so the support path is unclear right now but I intend to ask a favor with a Microsoft friend to see if I can get to the bottom of this. Additionally, for the company that is having the same problem. I'm working with them to run some tests in a test call queue to see if the system works properly despite the warning message. I'll post an update here as soon as I have more detail.

I too am seeing this problem since last week and still present today. I have opened a support case with Microsoft.

Yup. i started seeing this recently - I have also an open call with Microsoft

We got the same issue. Voicemail is working, but the announcement message does not play. It rings endless and simultaneously it records the users voice and sends it via voicemail. This is a massive problem. We opened a ticket but microsoft support is really annoying. After serveral days we got no solution, still waiting -.-

@Yannick_1337 We are having the same issue too! 

I am also seeing this message, but the Voicemail greetings does still work regardless, so it's not the end of the world if it continues to work like this.
So this is the response - i have no issues across our CQs at all everything works but they confirmed a bug. (Microsoft) Wednesday, November 10, 2021, 4:22 AM GMT
It's been my pleasure to assist you on this request to the best of my abilities, unfortunately, this time on an ongoing issue marked as a bug.

@gdackerm - Hey all, I just thought I'd jump in here and say I have just had had the same issue for one of my customers. In this case, the voicemail message wasn't playing so this had serious production impact and as they deal with patients in a crisis, I had to seek a workaround.


I have just implemented a workaround whereby the call queue redirects to an Auto Attendant rather than directly to voicemail. On this newly created Auto Attendant (with a resource account), I have this set to 'play a greeting message', then 'redirect to voicemail' (with suppress voicemail message enabled too). I have just carried this out for 13 of their call queues and it appears to work without any issues.


See screenshot of the new Auto Attendant, once this is created, just forward the call queue timeout/overflow to the new Auto Attendant. :)


Screenshot of call queue:


Hope this helps some people whilst Microsoft resolve the bug.





This doesnt work. Greeting Message isnt played.
The error message is now gone, but voicefile is still not playing!
For my Call Queues, I just did a dial in test where I had it time out to voicemail and it answered fine and my message showed up in Teams for the members of the Call Queue, and the error no longer appears in my Team admin portal when editing the Call Queues, so for me this issue is resolved. I hope Microsoft does better testing before releasing changes in the future.
I encountered this today - I don't recall being prompted to select a language in the original Call Queue setup... but I when I went in to edit a Call Queue to set it to send to a group voicemail inbox I received the error.

I got around it by using PowerShell. Using Get-CallQueue listed all my Q's with a LanguageID as BLANK, "", null... So -
Set-CsCallQueue -Identity <CallQGUID> -LanguageID en-US

en-US for me or any other valid language id I will assume get you around this error.