MTR not installing Windows Updates on reboot

%3CLINGO-SUB%20id%3D%22lingo-sub-958495%22%20slang%3D%22en-US%22%3EMTR%20not%20installing%20Windows%20Updates%20on%20reboot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-958495%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%2013%20Lenovo%20ThinkSmart%20Hub%20500%20MTR%20devices%20and%20have%20recently%20discovered%20that%20they%20are%20not%20installing%20Windows%20Updates.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20them%20configured%20on%20the%20domain%20and%20have%20internet%20access.%20We%20have%20policies%20for%20them%20to%20install%20the%20updates%20but%2C%20despite%20this%2C%20during%20their%20nightly%20reboot%20they%20still%20won't%20install%20them.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20experienced%20this%20before%2C%20or%20does%20anyone%20have%20any%20tips%20on%20how%20to%20force%20install%20the%20Windows%20Updates%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWorth%20mentioning%20that%20the%20MTR%20app%20itself%20updates%20fine%20(along%20with%20other%20Windows%20Store%20apps).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-958495%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-960021%22%20slang%3D%22en-US%22%3ERe%3A%20MTR%20not%20installing%20Windows%20Updates%20on%20reboot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-960021%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30238%22%20target%3D%22_blank%22%3E%40Daniel%20Hudson%3C%2FA%3E%26nbsp%3BWe%20are%20experiencing%20the%20same%20on%20our%20Lenovo%20Hub%20500s.%20We%20have%20seen%20it%20in%20the%20past%20on%20some%20units%20when%20it%20comes%20to%20.NET%20updates.%26nbsp%3B%20This%20time%20it%20is%20the%201903%20updates.%20Some%20of%20our%20devices%20are%20are%20not%20passing%20mic%20audio%20to%20the%20far%20end%20until%20we%20reboot%20or%20install%20the%20update%20manually.%26nbsp%3B%20We%20have%20about%20300%20Lenovo%20Hub%20500s%20and%20growing%2C%20so%20manual%20update%20pushes%20are%20not%20ideal.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20opened%20tickets%20with%20Lenovo%20and%20Microsoft.%26nbsp%3B%20They%20have%20not%20found%20any%20issues%20in%20the%20logs.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1795934%22%20slang%3D%22en-US%22%3ERe%3A%20MTR%20not%20installing%20Windows%20Updates%20on%20reboot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1795934%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20is%20still%20occurring.%20How%20about%20you%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30238%22%20target%3D%22_blank%22%3E%40Daniel%20Hudson%3C%2FA%3E%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1798853%22%20slang%3D%22en-US%22%3ERe%3A%20MTR%20not%20installing%20Windows%20Updates%20on%20reboot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1798853%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F170332%22%20target%3D%22_blank%22%3E%40James%20McGuire%3C%2FA%3E%26nbsp%3BHi%20James.%20We%20found%20in%20the%20end%20it%20was%20Group%20Policy%20preventing%20the%20device%20from%20rebooting%20and%20installing%20updates.%20We%20changed%20up%20out%20policy%20settings%20for%20the%20MTR's%20and%20they're%20working%20as%20expected%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1800011%22%20slang%3D%22en-US%22%3ERe%3A%20MTR%20not%20installing%20Windows%20Updates%20on%20reboot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1800011%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30238%22%20target%3D%22_blank%22%3E%40Daniel%20Hudson%3C%2FA%3E%26nbsp%3BWe%20currently%20are%20not%20managing%20the%20Update%2FReboot%20times%20and%20have%20devices%20with%20mic%20issues%20all%20the%20time%20due%20to%20.NET%20updates%20waiting%20to%20install%20and%20sometimes%20Feature%20or%20Cumulative%20Updates%20hanging.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhere%20are%20you%20managing%20these%20policies%3F%26nbsp%3B%20I%20am%20on%20the%20hardware%20side%20of%20life%20but%20trying%20to%20help%20find%20a%20solution%20for%20our%20overwhelming%20fleet%20of%20these.%26nbsp%3B%20Currently%2C%20we%20have%20some%20policies%20kicked%20out%20to%20the%20devices%20by%20Azure.%26nbsp%3B%20%26nbsp%3BAre%20there%20any%20built%20in%20Update%2FReboot%20times%20on%20the%20devices%20you%20had%20to%20bypass%20before%20adding%20your%20own%20policy%3F%26nbsp%3B%20%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20for%20all%20the%20questions.%26nbsp%3B%20%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1802124%22%20slang%3D%22en-US%22%3ERe%3A%20MTR%20not%20installing%20Windows%20Updates%20on%20reboot%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1802124%22%20slang%3D%22en-US%22%3EHi%20James.%20Ours%20are%20connected%20to%20AD%20on-prem%20so%20get%20local%20group%20policy%20from%20our%20AD%20DC's.%20I%20don't%20control%20or%20manage%20group%20policy%20so%20sadly%20don't%20have%20much%20I%20can%20share%2C%20other%20than%20knowing%20it%20was%20an%20issue%20with%20our%20Windows%20Update%20policy%20that%20caused%20the%20problems.%3CBR%20%2F%3E%3CBR%20%2F%3EMight%20be%20worth%20looking%20into%20it%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fadministration%2Fwindows-server-update-services%2Fdeploy%2F4-configure-group-policy-settings-for-automatic-updates%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-server%2Fadministration%2Fwindows-server-update-services%2Fdeploy%2F4-configure-group-policy-settings-for-automatic-updates%3C%2FA%3E%3C%2FLINGO-BODY%3E
Highlighted
Super Contributor

We have 13 Lenovo ThinkSmart Hub 500 MTR devices and have recently discovered that they are not installing Windows Updates.

 

We have them configured on the domain and have internet access. We have policies for them to install the updates but, despite this, during their nightly reboot they still won't install them.

 

Has anyone experienced this before, or does anyone have any tips on how to force install the Windows Updates?

 

Worth mentioning that the MTR app itself updates fine (along with other Windows Store apps).

5 Replies
Highlighted

@Daniel Hudson We are experiencing the same on our Lenovo Hub 500s. We have seen it in the past on some units when it comes to .NET updates.  This time it is the 1903 updates. Some of our devices are are not passing mic audio to the far end until we reboot or install the update manually.  We have about 300 Lenovo Hub 500s and growing, so manual update pushes are not ideal. 

 

We opened tickets with Lenovo and Microsoft.  They have not found any issues in the logs.

Highlighted

This is still occurring. How about you @Daniel Hudson

Highlighted

@James McGuire Hi James. We found in the end it was Group Policy preventing the device from rebooting and installing updates. We changed up out policy settings for the MTR's and they're working as expected now.

Highlighted

@Daniel Hudson We currently are not managing the Update/Reboot times and have devices with mic issues all the time due to .NET updates waiting to install and sometimes Feature or Cumulative Updates hanging.  

 

Where are you managing these policies?  I am on the hardware side of life but trying to help find a solution for our overwhelming fleet of these.  Currently, we have some policies kicked out to the devices by Azure.   Are there any built in Update/Reboot times on the devices you had to bypass before adding your own policy?   

 

Sorry for all the questions.   

Highlighted
Hi James. Ours are connected to AD on-prem so get local group policy from our AD DC's. I don't control or manage group policy so sadly don't have much I can share, other than knowing it was an issue with our Windows Update policy that caused the problems.

Might be worth looking into it here: https://docs.microsoft.com/en-us/windows-server/administration/windows-server-update-services/deploy...