MS team room : Teams is currently experiencing an error

Copper Contributor

Our Microsoft team room update to window 11 IOT version. And some of the room show the error  "Teams is currently experiencing an error. If the problem persists, please try restarting your device or talk to your administrator". It need to restart two times to resolve the issue.  This is the first time we see this error, and have no such information can be search. May I know if other people is facing the same issue as us? 

 

Team room error.jpeg

 

#Microsoft Teams room, #Activity, #Analytics

38 Replies
We are having this issue as well. Have restarted multiple times. Nothing has changed on our end.

I've checked the sign-in logs and no issues there. I cannot figure out what is causing this. 

Also experiencing this fault, no ideas?
I tried to run a repair and I get the "OS version not compatible."

We have over 30 Teams Room and this is causing us all kinds of issues. Everything just upgraded to Windows 11 and this new Teams version @Jarcque_Admin 

We have multiple systems that doe this many times a day. Doesn't help when you are in a meeting. Has anyone found a solution for this? Everything has been working with Windows 10. 

I managed to get it working, The powershell script for the had an error which I fixed, I also assigned a Teams Room Pro license. the NUC is running well now it seems.

@Jarcque_Admin which powershell script? We are also seeing this problem. Thanks!

@Jarcque_Admin thanks. We are already on the latest MTR version. Are you saying that re-applying it may fix the error? Thanks again!

That's correct, ours were on the latest version as well.

@Jarcque_Admin 

 

We have a customer with 25 devices with this issue, both Crestron and Poly, all on latest version.

@Jarcque_Admin thanks. Will try re-applying the MTR script on one device and see!

you will notice the recovery tool download has "11_22H2" folder in the download, the powershell "RecoveryTool.ps1" script has it excluded. On line 16 add 22621="11_22H2"; this will add the current version of win11.

Run the tool and select 2, Then run Reset on the device thought the settings menu and ensure to select Remove Everything.

To review what you did to fix it is just manually update the system. It was on the latest version but you just manually updated it again and that fixed the issue? @Jarcque_Admin I’m wiping and reloading one now with a flash drive I setup. This would be way easier if this fixes it although the jump drive wipe and reload is pretty easy.  

@Jay_Burgess875 Here is the fixed ps script if your device is running the latest win11 version. Extract to the "Skype Room System Deployment Kit" directory and replace the old ps file.

@Jarcque_Admin Is this script just for recovery or do you run this after you update teams?

Is the script to update teams (the one on this page: Manually update a Microsoft Teams Rooms device - Microsoft Teams | Microsoft Learn) broken or do you just run this once on windows 10 and then once after the update to windows 11?

Script is for the recovery. If you are unable to sign in running on win11 after your win10->win11 update, run the recovery.

if you run the recovery tool and it gives a version error, copy the script I pasted at the top. it will add the win 11 22h2 to be included.
I tried to manually update and it says it already has that version installed. I'm guessing I need to update something in the PowerShell Script.