SOLVED

Microsoft Teams not working on MacOS

New Contributor

Hi, 

 

so I downloaded and installed the MS Teams app today (24.2.2021) and it went well. But after the instalation was done and I tried to open the Teams app, it showed me only the small window saying: "Loading Microsoft Teams..." It was like this for about two hours when I realized its not probably gonna work. It doesnt show me the sign in window or anything like that. 

 

I tried re-installing and also deleting and installing again, but nothing worked.

 

Has anyone else experienced this? Can anyone help?

 

Thanks a lot.

20 Replies

@ThereseSolimeno 

 

Hi, thanks for sharing those links. On one of them I found that people are having the same problem, but there was no answer or reply with tips/ instructions on how to fix it. 

 

So I found out that people have the same problem, but I havent found any solution to it. 

 

Anyhow, thank you for your input. I really appreciate it.

Hmm...sorry about that, I should have read through every entry. You might want to just go to answers.microsoft.com tech support site for personalized service. When you give you a response, it would be great if you could post it here.
best response confirmed by dominikagrg (New Contributor)
Solution
Yes. I went trought a lot of other sites and today I have found an answer to my prayers. :)
So, to make it work - for anyone that might be having the same issue - Just open any invitation to a call/ meeting or any notification about being added to a new Team in your emails, and it should open the MS Teams app with "Sign In" window and then it should be working. This helped me, so I hope it can help also anyone that might be having the same problems. :)
I've been using Teams on my Mac desktop and laptop for over a year (following the instructions you describe here = pretty straight forward). Just last week - for no apparent reason - it stopped working with exactly the same symptoms as above: it gets stuck loading Microsoft Teams. I have just uninstalled and reinstalled the application and it still has the same problem.

If Microsoft wishes to remain in the game I strongly suggest you find a solution to this problem, as Mac users will increase pressure on the industry to use other platforms to meet if this persists.

@amandasheedy I have the exact same issue - been using it for >1 year and stuck loading. I have tried every solution out there to no avail. 

These instructions on howtoisolve dot com solved the problem for me:

Remove the cache associated with the Teams App. The system and app-generated cache files make the operation smoother and faster. However, not all the time, cache benefits the system and could create issues while using it.
Finder stores all the cache files and folders of applications installed in Mac. We’ll remove the cache from the Finder and restart the Mac.
1. Open Finder.
2. Click on Go > Go to Folder.
3. Type ~/Library/Caches and hit Return key.
4. Locate and remove com.microsoft.teams folder.
5. Likewise, navigate to the ~/Library/Application Support/Microsoft/Teams and delete the following folders:
    * Application Cache/Cache
    * blob_storage
    * Cache
    * databases
    * GPUCache
    * IndexedDB
    * Local Storage
    * tmp

Took a while before Teams started up after that, but at least it did…

@jamesvdh 

I followed your suggestion to the letter, but still had no success. I also seem to have another problem: I seem to be automatically registered to a University site, and cannot delete it, nor modify it. It's also iPhone size screen, without any possibility of getting it computer screen-sized. Any suggestions how to get around the problems?

 

@jamesvdh Teams had worked fine on Mac.  All of a sudden it stopped working.  Your steps worked great.  Thanks.

@dominikagrg Personally the only thing that worked for me was: 

- Uninstalling Teams

- Deleting Microsoft Teams from the Library

- delete com.microsoft.teams from the Caches

 

And then reinstall! 

@camillap 

just open your invitation link. it will guide through.

@jamesvdh If you're already signed in then this works. You must follow the above steps, followed by uninstall app and reinstall. Thanks @jamesvdh!

@dominikagrg 

 

After the Teams desktop app had been working fine on my MacBook Air for some while, I suddenly had the same problem with the "Loading Microsoft Teams" block hanging on my screen and the Teams app just displaying a blank screen.

 

I tried all the solutions I have so far read and all have failed, so I tried this.

 

Go to teams.microsoft.com and log into Teams there. Once you are logged in and see the Download the App prompt bar, click on that and the app will re-download. Once it has downloaded, open the app and it should run fine again - mine did after many hours of frustration trying other solutions.

 

I hope this works for you if you have been experiencing the same problem!

@dominikagrg I don't know if this is still an issue for you but I found something which worked for me. I had exactly the same issue. 
Completely uninstalled the teams app and the cache for it too including anything from the web version.

I then installed the app

onto my phone after first uninstalling it. I then logged in and as part of this I received an email. I opened the email on the Mac and followed the link to download and log into the app. Ta daaaa. It's all working lovely.

 

It worked for me anyway.

@dominikagrg Recently had this issue, I solved it by

 

1. Force quit the teams app

2. run "rm -r ~/Library/Application\ Support/Microsoft/Teams" in the terminal

3. Move the installed teams application into the bin and delete it permanently

4. Download the latest version of the teams app and install it from scratch

 

This should make the teams work properly.

@dominikagrg 

Quit the Teams APP if not already

Pass this command in the terminal

Restart Teams

 

It should work normally.

Forgot to paste the command,

rm -r ~/Library/Application\ Support/Microsoft/Teams

@dominikagrg - Click on Mac Go menu and press option key - which will show Library option and click on Library - Application Support - Microsoft and delete the Teams folder. Restart the teams app and it will ask you to login again and now you should be able to join meetings.

 

Thanks

@jamesvdhLikewise, navigate to the ~/Library/Application Support/Microsoft/Teams and delete the following folders. 

 

I deleted the complete Teams folder not only the ones you mentioned and it worked for me. Hopefully it would for others.