Microsoft Teams integraions fail to connect with many applications

New Contributor

Hello everyone, I hope you are doing well. Recently, I have decided to move on and start using Microsoft Teams within my team. On a daily basis we use multiple integrations including Zapier, Zoom, and RingCentral. However, I have been facing issues to get these integrations working. None of them actually works. They are there, in the apps section but they don't work.

For instance, Zoom integrates and asks me to "click here" to login. I login, it congratulates me on connecting Zoom but it fails to setup meetings asking me to login and when retrieving data from "My meetings" it fails and asks me to sign in "loops in this cycle".

Another example is Zapier, tried to link my account from Zapier's side, it asks me to login to Microsoft. I do and then it gives me an error 401 which has to do with Authentication. So I thought of doing the entire process in an Incognito window, same results. Moving on with Ringcentral, integrates, but similar issues like Zoom. The only thing that all these integrations have in common is Microsoft Teams so I am not sure where I am going wrong here. I have even tried to setup a new microsoft teams account but faces the same exact issues.

Thank you in advance

5 Replies


When it comes to apps working with Teams the functionality is great so far and mostly if something is not working then it is not the fault of Microsoft teams as those apps are registered to Teams apps stored and design/developed by their own prospective vendors;


As far zoom working with Teams is great I am sure you have configured at the right way but here is the latest version of zoom app for Teams;


Here is the link for Zapier


Here is the latest article on connecting the Ringcentral to MS Teams;


so i would suggest try to remove and reconfigure and check the integration step by step.

@PDostiyar Thanks for the reply. Actually none of the integrations worked. As I mentioned previously, I created a new account on a new email just to see if the integrations would work. They didn't so I am not sure how would that be different from deleting the integrations and trying again.

For example. Zoom integrated > asks to sign int > "happy zooming" > go back and @zoom start > asks to sign in > signs in > message saying "something went wrong"


Thanks again.

@skhetchoohh really I am not sure if that is the Teams or the app itself, or even it could be your computer you are trying to do it,


have you ever tried configuration on another computer or on the web version of MS Teams?

@PDostiyar Yes! I did try it with the web version. I am 100% sure it is not my PC as I also tried it from a different PC. Also I thought this might be happening because It is not a paid account. So I tried to upgrade to a paid account and I faced this error as well


I am getting this message for the freshly created account as well as the company account. It's just a problem after a problem.

Thank you and kind regards.

@skhetchowill when it comes to your paid account that should work if not I would suggest opening a ticket with those products I am not sure if you got paid or free account there which will affect their support model.

besides the screenshot, you attached seems that it is a new free account I believe.


Lastly for your once you get feedback from zoom and others if that is not helpful or if there is no problem from them opening a ticket to Microsoft for your paid one will be an option too.