Login Loop in Ubuntu

Copper Contributor



I'm using Teams on Ubuntu and have trouble connecting to my account, the app and on the website, being stuck in a login loop. It's only teams that has issues, the rest of the microsoft account works fine.  Quite the same problem as here:


but the solution given, set a correct time, is not working, actually, my time is correct. Then I don't know what to do.


Would you have a solution for me?

Thank's in advance,

Adrien de Hesselle

4 Replies

@adehes I tried uninstalling and reinstall Microsoft Teams and it worked. I didn't find any other solution.

@adehes Did you figure it out?


I have the same problem. I tried logging in to Teams through ...

  • the preview version (installed via `sudo apt install teams`)
  • the insiders version (installed via `sudo apt install teams-insiders`)
  • web version on Google Chrome (version 87.0.4280.141 - 64bit)
  • web version on Firefox (version 84.0.2 - 64bit)

Noe of it works, which makes me suspect that there's some issue with my clock settings. I've got automatic time synchronization switched on.


Note that I can log in to other Microsoft services like Outlook without any issue.

I ended up just installing the snap version as I could never get the deb version from the Microsoft website to work.
`sudo snap install teams`

@adehes For me it was incorrect clock time. I manually set time in ubuntu and it started working.