Locked out of MS Teams

New Contributor

Hi Everyone,


Any help on this issue appreciated!


I set up MS Teams on my Windows laptop a few weeks ago. For several weeks everything was fine, but now I find that I cam locked out of the 'Organisation'. The message says: 'You don't have access to the [my organisation] org in Teams. Select another org, or contact your admin for more details.'


Now when I try to sign out and sign in, I get a message saying: 'We're switching you to your other account. It will just take a moment...' but I don't have any other account! This happened after I had been added as a guest by another organisation. I have asked the other organisation to delete me as a guest. They say that they have done so, but they still show up on the drop-down of available organisations.


I have occasionally used a personal hotmail account on this laptop, but have now tried to remove it using the 'Credentials' settings. I never associated it with Teams.


I am able to log into the MS Teams account fine if I use my Mac. However, if I try to do anything on my main laptop (including log in via the web rather than the app) it won't work. It is as though my own machine doesn't recognise me.


Can anyone help?


4 Replies
best response confirmed by ThereseSolimeno (Microsoft)



Hi, it seems odd that you can login on your Mac, and yet not via the browser on your Windows device.  Out of interest, which browser(s) did you try on your Windows device please?  May be worth trying some different browsers to the one you tried.  If that works, the the problem is going be localized to the Teams Client App on the Windows device I would think.

Hi @PeterRising 


I think I used Edge on the laptop, but I will try other browsers as you suggest.


Yes, it works absolutely fine on the Mac. Strange.


If I still have problems, I will look at the Teams Client App.


Many Thanks,



Hi @PeterRising 


So I tried to log in via the web but this time using Internet Explorer instead of Edge - it worked!


Browsers are weird! In my day job, I have been helping Care Homes access NHSmail. When they first login, it is not unusual that they have problems that are fixed simply by using a different browser!


Thanks for responding so quickly and pointing me to right solution.


Best Wishes,




It's a pleasure,  at least we know now it's the Teams App on that PC.  So you can try a reinstall / repair maybe as the first step to troubleshoot that.