SOLVED

Can't Configure Azure DevOps Connector in Teams (HTTP ERROR 500)

Highlighted
New Contributor

We are trying to configure the "Azure DevOps" connector in a Teams channel. It has already been added to the channel, so I go to the channel, click the three dots, and click "Connectors."

 

JohnMotoMiner_0-1598465063966.png

 

Then, I click the "Configure" button next to "Azure DevOps":

 

JohnMotoMiner_1-1598465121714.png

 

That then opens a window that says, "To add this connector, sign in to your Azure DevOps account", so I click the "Log in" button.

 

That then browses the login window to a screen that looks like this:

 

authenticate.png

 

I click "Continue", and it takes me to a screen to login to my MS account, and I click on my MS account that is currently "Connected to Windows":

 

pick-an-account.png

 

After clicking the account, it redirects a few times and ends up showing "https://outlook.office.com" in the window header and nothing but a blank, white screen below:

 

white-screen.png

 

I've tried this process over and over again, and even had another coworker follow the same process, and none of us can get anything to appear in the window.

 

I went to the browser version of Teams and did the same process. There was one difference once I got to the blank, white screen bug, which was that the popup window showed a 500 error:

 

"This page isn’t working

outlook.office.com is currently unable to handle this request.

HTTP ERROR 500"

 

500-error.png

 

Anyone have any idea what's going on?

20 Replies
Highlighted
the same happens to me, any help?
Highlighted

@JohnMotoMiner I have an open case on the exact same issue and will let you know if I get a fix of some sort.  My Microsoft technician has got as far as it's to do with outlook and where it's hosted (on-prem seems to not play nicely).  However, we have outlook online so it's being escalated as of now.  I also used to get an error regarding the access token but since I removed the previous configuration I now can't configure it at all! 

lfhighaimer_0-1598893378885.png

Here's to hoping... someone can help get this sorted! 

Highlighted
@lfhighaimer, great to know we're not the only ones experiencing this and that MS is aware! Thanks for the details. We use Office 365 here.
Highlighted

@JohnMotoMiner Same here, when I tried to connect with browser got following response

hafeez1042_0-1598924537552.png

 

Highlighted

I'm having the same issue as well. I'm getting a blank page upon logging in.

Screen Shot 2020-09-02 at 12.09.09 PM.png

Highlighted

@Mary Jane Cruz As many of you who can should get a message into Microsoft to let them know this is going on. I'm afraid that if @Octavio_Vallejo is the only one who has submitted a support request on this, they won't think it's that big of a problem. Octavio can correct me, but I believe the way to submit a request is through: https://admin.microsoft.com/

Highlighted

@lfhighaimer any traction on the support case?

Thanks

Highlighted

@sheesh8080 Unfortunately, not much traction apart from collecting logs and still in escalation.  I'll chase up again and inform the technician of this thread.  Will post back with any updates as soon as I have any.  

Highlighted

@JohnMotoMiner I can confirm that this is the way to raise a support case using the "Need Help" label hovering on the right hand side of the page when signed is an admin.  I've forwarded this thread onto MS so waiting to hear back - hopefully today!

Highlighted

@JohnMotoMiner I'm having the same problem, the url mentions an invalid scope. I wonder if its a permissions thing. My boss doesn't have a problem creating connectors, only I do. Not sure what permission I am missing

Highlighted
Highlighted

@JohnMotoMiner Just noting that I am also experiencing this issue. Would love updates if anyone finds anything.

Highlighted

I'm experiencing this at my organization, as well. I asked my manager to give it a try because he has administrative privileges across the tenant (whereas there are some gaps in my privileges), but he had the same result.

Highlighted

@sheesh8080 Not as of yet.  I've been called and emailed each day to say it's being looked at and sorry for the delay.  It seems, Microsoft are fixing something on their end which solve it for all of us - I hope!  HTTP 500 /invalid scope suggests something is broken on the server side so I'm guessing it's maybe a side effect of the known issues (#3) for the ADO connector https://docs.microsoft.com/en-us/connectors/visualstudioteamservices/#known-issues-and-limitations

Highlighted
Best Response confirmed by JohnMotoMiner (New Contributor)
Solution

@JohnMotoMiner@sheesh8080 Just got a call from MS to say they will be rolling out an update on the 17/18th of Sept!  No indication of what the cause might be but hopefully we'll be able to get our ADO/Teams integration powers back this week :)

Highlighted
Highlighted

Looks like this was resolved on the 17th! I was able to add/configure a new DevOps connector to one of my channels, finally. :)

Highlighted
I can concur, this is now working! Thanks for reminding me to check again, @filetrail_dgrossman! And special thanks to @lfhighaimer for keeping us up to date on the case with MS. Cheers to you all!
Highlighted

@JohnMotoMiner , the issue seems fixed by Microsoft team, now I can use Azure DevOps connectors.