Camera showing Black Screen only when using Teams app, works with Web version

Copper Contributor

Hi guys,

A client is using Windows 10 x64 running v1909 on a MacBook Pro 13" (2019, 4 Thunderbolt Ports) and oddly enough the Teams app now shows the Camera as a Black Image as the Preview. It's listed in Device Manager as FaceTime HD Camera. Zoom and Web Teams works completely fine. Even opening the MS Store Camera App loads the Camera fine. It's just isolated to the Teams App, I'll list what I've tried already below, really hoping you can help in any way.


-Re-installed Teams x64

-Attempted to install Teams x86 - No change

-Removed Camera Driver and re-installed via Bootcamp drivers

-Re-installed ALL Bootcamp drivers from the latest available updated

-Cleared Teams cache folder

-Office Quick Repair/Full Repair


The problem still exists but only with the Windows app version of Teams.


If you have any ideas or thoughts please let me know.

Thank you,



40 Replies

Same thing. MacBook Pro 13'' 2020 4 Tunderbolts.

Only Teams showing the camera as a fully black image, all other apps using the camera are working.

Win 20h2. Teams (64-bit).

Reboots, reinstall of Teams, reinstall of drivers... Nothing helps.

Worked fine up to now.


Make sure to report this via help-> Feedback in the client!


@Jan Driesen Thanks Jan. I'm not going crazy in that case. The user said she was running it fine up until this point too. I've restored Windows Update back to v1909 from v2004 but it didn't help. Looks like something permanent has been triggered. I tried an older version of Teams too (1.33 I think) but this did the same thing. @adam deltinger  Thanks for this mention, I've done this now. I'm hoping it gets somewhere but for the user will just have to use Web Teams as a workaround for video calls. 


Thanks for the input though guys.

hey man,

A user on my end has been having the same issue. also tried reinstalling teams and the webcam driver but unfortunately still the same issue.

have you tried the "windows support" software from apple.

Hi @Ruben-D unfortunately yes, I got a USB made up of the Windows Support Software from Mac OS and tried to perform a Bootcamp repair, it still didn't work unfortunately. Pretty weird issue, I've submitted the Help>Feedback now so hoping for something along the line.


Hope we get a fix but at least in the meantime there is the web version.


I did an update of MacOS, then created the USB driver set. After running the bootcamp repair in Windows, the issue disappeared. I'm not sure whether this was caused by the OS update or the repair of bootcamp. Since installing Windows, I had never booted MacOS, so it is unlikely that the cause of the issue was in MacOS.

Thank @Jan Driesen I'm glad you got it working in the end for you. I did notice that after running a Bootcamp repair in Windows via the Mac OS made USB Drivers that the Camera did work the first time I did this. The client then obviously rebooted the machine the next day and it was broken again, running the Repair didn't bring the Camera back and hasn't. All out of ideas, clients using Web Teams for now (hating it) but no other choice.

Hey guys,


is there any solution yet? I've a user experiencing the same issue... Event log doesn't report any errors... already reset the camera permissions but no avail... At the OS level all "seems" fine (Camera led lit up, in setting its visible that the camera is being used,...) 


Any fresh ideas?

@Sh3rl0ck3000. I got this fixed the way you may find above.

But today this happened to me again. Same issue, only in Microsoft Teams. Only this time running the repair stick doesn't help... I'll try to run some reinstalls and updates along the way to see if that fixes it. I'll report in here if it does.



I have this running teams on VMs like crazy. All other apps work fine. What is wrong with MS Teams?? How are we supposed to rely on this service if we can't even use our webcams??

best response confirmed by harminderchagger (Copper Contributor)



I have been having this issue as well and have found a hacky solution. It seems that when you initiate the camera in Zoom, it stops it from working in Teams. The only way to get it working again in Teams is:


1) Reboot into Mac

2) Download/Open Teams app on Mac

3) Initiate camera (either start a video call or test camera in Teams > Settings > Devices)

4) Reboot into Windows and the camera on Teams should be working again.


HOWEVER as soon as you start the camera on Zoom again (also seems to happen with Google Meet), it will stop working on Teams and you will have to repeat the process above.


It seems using the camera on Zoom/Google Meet causes the camera to become incompatible with Teams (and also Skype). Hopefully an actual fix to this is coming soon


I traced back my meetings and indeed this happened after a google meet meeting using a webcam.

Rebooted to mac os, started the webcam in teams. Go back to Windows, and indeed the camera works again.

I can hardly call that a solution, but knowing that this can bring it back is good. Thanks!

Amazing little hack there! I'll give this a go at some point this week with the client. Very weird behaviour but at least you've found a way to replicate this behaviour so its sort of a fix.


Thanks for your effort :) @raphaj 

Thanks for trying this Jan, glad it's working again albeit in a strange way. I'm guessing its not going to be anytime soon that Microsoft will be able to fix this. @Jan Driesen 

@harminderchagger we are chasing MS for many months for this issue and finally have the solution. see if that works for those who are using MacBook with windows 10 boot camp option. follow the below steps:

  1. Quit Teams application completely
  2. Start cmd as administrator
  3. Run this command echo {"RtmCodecsConfig":{"CapturerApiForce":"1"}} > %appdata%\Microsoft\Teams\SkypeRT\persistent.conf
  4. Verify that %appdata%\Microsoft\Teams\SkypeRT\persistent.conf was updated as expected.
  5. Start Teams again, and test the camera.




Hello to everyone. I solved my problem by changing the zoom settings

Open zoom>settiings>video>advanced>video capturing method> Media Foundation (non auto nor Direct show)

Restart the system in mac os test camera then restart to windows...problem Solved!
Hi @All,

problem solved: i had the same problem untill last friday 26.02.2021
today a made a few windows restartes and installed the last updates. now it works again.

@TechManish This solution worked for me, many thanks.

@TechManish This solution worked for me as well, many thanks.