Home

Adding a Bot to MS Teams: Sending new messages to this bot has been disabled

%3CLINGO-SUB%20id%3D%22lingo-sub-820977%22%20slang%3D%22en-US%22%3EAdding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-820977%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20created%20a%20QnA%20Bot%20in%20Azure%2C%20published%20it%2C%20and%20have%20attempted%20to%20open%20it%20in%20Microsoft%20Teams.%20However%2C%20when%20I%20do%2C%20I%20receive%20a%20message%20stating%20%22Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%20by%20your%20administration.%22%20I%20am%20the%20administrator.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20794px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F128331i6C62FB57ED3A1915%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22disabled.png%22%20title%3D%22disabled.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EI%20have%20spoken%20to%20two%20different%20Microsoft%20Support%20Engineers...%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20first%20Engineer%20told%20me%20that%20I%20needed%20to%20make%20sure%20that%20%22Allow%20sideloading%20of%20external%20apps%22%20was%20turned%20on%20in%20Office%20365%20(Settings%20%26gt%3B%20Services%20%26amp%3B%20add-ins%20%26gt%3B%20Microsoft%20Teams%20%26gt%3B%20Apps).%20It%20appears%20to%20be%20turned%20off%2C%20but%20the%20option%20to%20change%20anything%20here%20is%20grayed%20out%20with%20a%20message%20stating%20that%20these%20settings%20have%20been%20migrated%20to%20the%20new%20Microsoft%20Teams%20Admin%20Center.%20This%20is%20when%20the%20Engineer%20asked%20me%20to%20create%20a%20new%20case%20with%20Office%20365%20to%20get%20this%20turned%20on.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20504px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F128332iCD7972F819241423%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22old_settings.PNG%22%20title%3D%22old_settings.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20created%20a%20new%20case%2C%20spoke%20to%20the%20second%20Engineer%20who%20told%20me%20that%20those%20settings%20are%20now%20in%20the%20Microsoft%20Teams%20Admin%20Center.%20We%20navigated%20there%2C%20which%20I%20had%20before%2C%20and%20verified%20that%20both%20%22Permission%22%20and%20%22Setup%22%20policies%20beneath%20%22Teams%20app%22%20is%20set%20correctly.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20828px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F128333i83B2C1220B145B20%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22teams1.PNG%22%20title%3D%22teams1.PNG%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20806px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F128334i874EFDC21FA1D879%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22teams2.PNG%22%20title%3D%22teams2.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20second%20Engineer%20didn't%20have%20an%20answer%20and%20told%20me%20that%20he'd%20get%20back%20to%20me%20because%20the%20settings%20are%20correct.%20Anyone%20have%20any%20ideas%3F%20Any%20advice%20is%20greatly%20appreciated!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-820977%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-821068%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-821068%22%20slang%3D%22en-US%22%3E%3CP%3EUpdate%3A%20The%20second%20Engineer%20followed%20up%20via%20email%20with%20a%20canned%20reply%2C%20sharing%20URLs%20for%20Microsoft%20Teams%20documentation%2C%20none%20of%20which%20were%20related%20to%20the%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-823378%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-823378%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F397640%22%20target%3D%22_blank%22%3E%40scsh4%3C%2FA%3E%26nbsp%3BOn%20that%20%22Permission%20policies%22%20screen%2C%20click%20on%20the%20button%20at%20the%20top%20right%20%22Org-wide%20App%20Settings%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20page%20has%20more%20detail%20for%20me.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-870651%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-870651%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F181711%22%20target%3D%22_blank%22%3E%40Angela%20Detzel%3C%2FA%3E%26nbsp%3Band%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F397640%22%20target%3D%22_blank%22%3E%40scsh4%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20it%20work%20for%20you%3F%20I've%20been%20trying%20to%20make%20it%20work%20for%20weeks.%3C%2FP%3E%3CP%3EAll%20the%20configuration%20seems%20to%20be%20ok%2C%20but%20the%20communication%20is%20still%20not%20possible.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20going%20to%20open%20a%20ticket%20with%20Microsoft%20and%20just%20found%20this%20post%20here.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20have%20any%20updates%20about%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20very%20much!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-870673%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-870673%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F94915%22%20target%3D%22_blank%22%3E%40Rui%20Carvalho%3C%2FA%3E%26nbsp%3BThe%20last%20update%20provided%20was%20that%20they're%20aware%20of%20the%20problem%2C%20are%20working%20on%20the%20issue%2C%20but%20have%20no%20ETA%20on%20when%20it%20will%20be%20resolved%3B%20that%20the%20problem%20is%20with%20Microsoft%20Teams.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-870745%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-870745%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F397640%22%20target%3D%22_blank%22%3E%40scsh4%3C%2FA%3E%26nbsp%3BThank%20you%20very%20much%20again!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-870837%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-870837%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F397640%22%20target%3D%22_blank%22%3E%40scsh4%3C%2FA%3E%26nbsp%3BSame%20issues%20I%20have%20on%20my%20tenant!%20The%20Microsoft%20engineer%20checked%20all%20settings%20and%20it%20seem%20all%20right%20!%20But%20the%20issues%20is%20persistent.%20He%20said%20that%20he%20will%20get%20back%20to%20me...%20It%20was%20last%20week.%20Hope%20this%20week%20that%20I%20can%20hear%20from%20him.%20Not%20sure%20if%20he%20is%20in%20India%20or%20in%20the%20US.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-877796%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-877796%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F397640%22%20target%3D%22_blank%22%3E%40scsh4%3C%2FA%3E%26nbsp%3BAre%20you%20starting%20a%20conversation%20with%20your%20QnA%20bot%20via%20its%20bot%20ID%3F%20That%20is%2C%20as%20opposed%20to%20its%20name%2C%20which%20requires%20creating%20and%20uploading%20a%20manifest%2Fapp%20package%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20so%2C%20there%20is%20a%20fix%20for%20this%20being%20rolled%20out%20but%20it%20hasn't%20hit%20our%20public%20version%20yet.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20workaround%20is%20to%20create%20an%20app%20package%20(easiest%20way%20is%20to%20use%20the%20App%20Studio%20app)%20and%20load%20your%20QnA%20bot%20that%20way%2C%20by%20name.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBill%20Bliss%3C%2FP%3E%0A%3CP%3EMS%20Teams%20Platform%20Architect%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-877799%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-877799%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F28106%22%20target%3D%22_blank%22%3E%40Bill%20Bliss%3C%2FA%3E%3A%20Correct%3B%20the%20way%20in%20which%20I%20am%20referring%20to%20this%20is%20beginning%20the%20conversation%20by%20the%20BOT%20ID.%20Coincidentally%2C%20I%20heard%20from%20the%20Support%20Engineer%20that%20I%20have%20been%20working%20with%20today%2C%20who%20communicated%20the%20same%20thing%20as%20you%20just%20have.%20Thanks%20for%20your%20response!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-882772%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-882772%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F397640%22%20target%3D%22_blank%22%3E%40scsh4%3C%2FA%3E%26nbsp%3B%20I%20am%20also%20facing%20same%20issue.%20I%20have%20build%20normal%20conversational%20Bot%20it%20is%20not%20like%20yours%20QnA%20bot.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20also%20not%20able%20to%20ping%20that%20bot%20from%20MS-Team.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-882865%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20a%20Bot%20to%20MS%20Teams%3A%20Sending%20new%20messages%20to%20this%20bot%20has%20been%20disabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-882865%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F416957%22%20target%3D%22_blank%22%3E%40Hemanttoday%3C%2FA%3E%26nbsp%3BPlease%20post%20a%20new%20question%20with%20more%20details%20on%20Stack%20Overflow%2C%20our%20primary%20support%20site%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fstackoverflow.com%2Fquestions%2Ftagged%2Fmicrosoft-teams%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fstackoverflow.com%2Fquestions%2Ftagged%2Fmicrosoft-teams%3C%2FA%3E.%20Please%20tag%20it%20with%20%22microsoft-teams%22.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
scsh4
New Contributor

I have created a QnA Bot in Azure, published it, and have attempted to open it in Microsoft Teams. However, when I do, I receive a message stating "Sending new messages to this bot has been disabled by your administration." I am the administrator.

 

disabled.png

 

I have spoken to two different Microsoft Support Engineers...

 

The first Engineer told me that I needed to make sure that "Allow sideloading of external apps" was turned on in Office 365 (Settings > Services & add-ins > Microsoft Teams > Apps). It appears to be turned off, but the option to change anything here is grayed out with a message stating that these settings have been migrated to the new Microsoft Teams Admin Center. This is when the Engineer asked me to create a new case with Office 365 to get this turned on.

 

old_settings.PNG

 

I created a new case, spoke to the second Engineer who told me that those settings are now in the Microsoft Teams Admin Center. We navigated there, which I had before, and verified that both "Permission" and "Setup" policies beneath "Teams app" is set correctly.

 

teams1.PNGteams2.PNG

 

The second Engineer didn't have an answer and told me that he'd get back to me because the settings are correct. Anyone have any ideas? Any advice is greatly appreciated!

10 Replies

Update: The second Engineer followed up via email with a canned reply, sharing URLs for Microsoft Teams documentation, none of which were related to the issue.

@scsh4 On that "Permission policies" screen, click on the button at the top right "Org-wide App Settings"

 

This page has more detail for me.

Hi @Angela Detzel and @scsh4,

 

Did it work for you? I've been trying to make it work for weeks.

All the configuration seems to be ok, but the communication is still not possible.

 

I'm going to open a ticket with Microsoft and just found this post here.

 

Do you have any updates about this issue?

 

Thank you very much!

@Rui Carvalho The last update provided was that they're aware of the problem, are working on the issue, but have no ETA on when it will be resolved; that the problem is with Microsoft Teams.

@scsh4 Same issues I have on my tenant! The Microsoft engineer checked all settings and it seem all right ! But the issues is persistent. He said that he will get back to me... It was last week. Hope this week that I can hear from him. Not sure if he is in India or in the US.

@scsh4 Are you starting a conversation with your QnA bot via its bot ID? That is, as opposed to its name, which requires creating and uploading a manifest/app package?

 

If so, there is a fix for this being rolled out but it hasn't hit our public version yet. 

 

The workaround is to create an app package (easiest way is to use the App Studio app) and load your QnA bot that way, by name. 

 

Bill Bliss

MS Teams Platform Architect

@Bill Bliss: Correct; the way in which I am referring to this is beginning the conversation by the BOT ID. Coincidentally, I heard from the Support Engineer that I have been working with today, who communicated the same thing as you just have. Thanks for your response!

@scsh4  I am also facing same issue. I have build normal conversational Bot it is not like yours QnA bot.

 

I am also not able to ping that bot from MS-Team.

@Hemanttoday Please post a new question with more details on Stack Overflow, our primary support site: https://stackoverflow.com/questions/tagged/microsoft-teams. Please tag it with "microsoft-teams".

Related Conversations
Send message to Teams Bot from console
Kipetcoff in Microsoft Teams on
2 Replies
Bot messageback issue in 1:1
Tidfisto in Microsoft Teams on
10 Replies
Teams error code - 6
damnit95 in Office 365 on
4 Replies
Sharing a Teams Calendar
Michael Krueger in Microsoft Teams on
16 Replies