Tech Community Live: Microsoft Intune
Mar 20 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community
SOLVED

Intune Autopilot device registration error

Iron Contributor

Dear forum members,

I am autopiloting a mini PC, it was successful for the first time. Then the other day we sent a Wipe command to reset the device, once it came back, it stopped working during the Autopilot process with the following error: 

Failed registering your device to mobile management with error code 0x80180014.

Anyone could recommend any troubleshooting ideas?

 

What I already have tried is to delete the device from the Intune, AAD and Autopilot program. I re-upload the machine ID (csv file) back to Autopilot program. It created the AAD object successfully, but not under the Intune Device blade.

 

Thanks all.

8 Replies
best response confirmed by wangjueliang (Iron Contributor)
Solution
First troubleshooting idea comes to my mind is to check your Enrollment restriction Rules for devices, if all looks good, try below:

Create new Security Group (not Dynamic) and add it ‘member’ (make sure the status change to assigned) and give it another try.

If still not working, I would create new deployment profile and assign the new security group.

Hope this helps!
Moe

Thanks @Moe_Kinani 

I shall try re-create the group and assigned the device as direct member. Failing that, re-create the Autopilot profile will be my next step.

 

The Enrollment restrictions look okay. There is a rule that has been assigned to the device group already. The Windows MDM is to allow and Personal is to block. The Autopilot device should automatically become corporate owned, I guess.

 

Just to clarify, the device will hit the restrictions rules starting from the highest priority to lower ones. As soon as there is a hit, the restriction will apply (allow or block) and other lower priority rules will not process. 

 

Thanks for your help Moe.

Yes, agree. Highest priority rules always win!

Hi @Moe_Kinani, the error I am getting at the Autopilot enrollment status page is "failed: 6, 0x80180014". Google the error code takes me to the enrollment restriction page but I can't see how the current restriction settings are causing this.

Auto Pilot errors codes are not %100 accurate, I have been on the same boat before.

Have you tried creating new deployment profile and assign to Security Group that includes the effected device? I don’t see your Restriction rule will affect it as it hits personal devices.

I would leave disabling the existing restriction rule as last resort.

Hi @Moe_Kinani, I logged a support case and here is the official answer from Microsoft.

The user created enrollment restrictions only apply to user-driven enrollment. It is not supported for user-less enrollment using the Self-Deploying methods. So it will hit the default rule.

As soon as I allowed Windows MDM in the default enrollment restriction, it started working.

Thanks for your help my friend.

Thanks for the update wangjueliang!

@wangjueliang Old article, but you saved my day! I had a device with this error and it turned out to be the default enrollment restriction I made a change to the other day :)

1 best response

Accepted Solutions
best response confirmed by wangjueliang (Iron Contributor)
Solution
First troubleshooting idea comes to my mind is to check your Enrollment restriction Rules for devices, if all looks good, try below:

Create new Security Group (not Dynamic) and add it ‘member’ (make sure the status change to assigned) and give it another try.

If still not working, I would create new deployment profile and assign the new security group.

Hope this helps!
Moe

View solution in original post