Deployment of MacAfee agent

%3CLINGO-SUB%20id%3D%22lingo-sub-2558568%22%20slang%3D%22en-US%22%3EDeployment%20of%20MacAfee%20agent%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2558568%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20deploy%20the%20McaAfee%20agent%20via%20win%2032%20feature%20via%20Intune%20but%20till%20now%20there%20is%20no%20installation%20on%20client%20machines%20.Also%2C%20there%20is%20no%20Intune%20Management%20extension%20installed%20on%20client%20machines%20as%20well.%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20to%20troubleshoot%20this%20any%20suggestions%3F%3F%3C%2FP%3E%3CP%3EI%20have%20also%20checked%20the%20install%20and%20uninstall%20command%20and%20both%20are%20working%20fine%20but%20i%20don't%20know%20why%20the%20app%20is%20not%20getting%20deployed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2558568%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Application%20Management%20(MAM)%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2559615%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20of%20MacAfee%20agent%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2559615%22%20slang%3D%22en-US%22%3EHow%20are%20the%20client%20machines%20deployed%3F%20Azure%20ad%20or%20registered%20.%20Are%20you%20seeying%20the%20machines%20in%20intune%20%3F%20and%20with%20what%20status%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2559621%22%20slang%3D%22en-US%22%3ERe%3A%20Deployment%20of%20MacAfee%20agent%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2559621%22%20slang%3D%22en-US%22%3EClient%20machines%20are%20enrolled%20via%20AAD.%20Yes%20all%20machines%20are%20showing%20on%20intune%20portal.%3CBR%20%2F%3EBut%20after%20deployment%20of%20agent%20till%20now%20there%20is%20no%20Intune%20Management%20extension%20is%20not%20installed.%3CBR%20%2F%3EUnder%20assignment%20tab%20I%20have%20added%20the%20group%20of%20users%20under%20required.%3C%2FLINGO-BODY%3E
Occasional Contributor

I have deploy the McaAfee agent via win 32 feature via Intune but till now there is no installation on client machines .Also, there is no Intune Management extension installed on client machines as well. 

How to troubleshoot this any suggestions??

I have also checked the install and uninstall command and both are working fine but i don't know why the app is not getting deployed.

 

 

6 Replies
How are the client machines deployed? Azure ad or registered . Are you seeying the machines in intune ? and with what status
Client machines are enrolled via AAD. Yes all machines are showing on intune portal.
But after deployment of agent till now there is no Intune Management extension is not installed.
Under assignment tab I have added the group of users under required.

Are you experiencing no other issues while the intune mgt extension is not installed? is the mcafee agent the only app you are pushing or? 

 

What happens on a device when you install the agent manually? 

https://naprodimedatasec.azureedge.net/IntuneWindowsAgent.msi

https://prodmsub05data.azureedge.net/IntuneWindowsAgent.msi

Till now i have not deployed any other app this is the first task after enrolling the devices to Intune. I have not apply any policy via Intune.

Hi

Then I would recommend looking in to the why(the ntune mgt is not getting installed) and what happens when you try to install it manually. Normally when you are installing a win32 app or pushing a powershell script the mgt agent will be installed at that point

 

Add PowerShell scripts to Windows 10 devices in Microsoft Intune - Azure | Microsoft Docs

 

And could you give us some screenshots information about how you created the win32 app (the powershell / cmd script which would launch the installer silent from mcaffee)

@Rudy_Ooms Sure. Please find the screenshot.