Android for Work - Contacts?

Brass Contributor

Hi guys,

I'm testing out android for work, I've enrolled a device, which sets up Outlook via configuration policy, within the android for work profile, the contacts app does not populate, I've deployed settings to read \ write contacts for Outlook, I've set a configuration profile to auto grant permissions within the work profile.

When going to the outlook settings and selecting 'Sync contacts' an error pops up and states 'contact permissions are not fully granted..." so within the workspace settings, I've checked the outlook app settings and the permission option for contacts is set to 'enabled by admin'.

Also, if I try to 'sync your accounts' from the AFW contact app, outlook does appear, I sign in and then I receive an error of 'This email address is already connected with Office 365. Do you want to connect it with another service?" and then I select O365 Outlook app again, but nothing really happens.

Is it supported to view contacts from Office 365 via the AFW contact app? (Not the personal contact app)? If so, how do I configure this?

16 Replies

@Durrante  In the app protection policy for Outlook, do you have contacts sync enabled?



I do indeed.

Hi @Durrante,


When you set the configuration profile to auto grant permissions within the work profile, did you set this using;

  • Device Restrictions profile, Default app permissions = Auto Grant
  • or; an individual Managed App config for Outlook?




Hi Andrew,

I have the same exact issue and I have the device restriction policy and tested with an APP configuration policy. 

But I have the same error. "Contact permisssions are not fully granted" when selecting "opening settings" on the Outlook App to grant permissions.


thanks to help

Note: Sync contacts to native app is enabled.



Try to change the Device configuration property "Default app permission" (under Work profile settings) to "Prompt" instead of "Auto grant". 


With Auto grant we had the same issue, as the system does not grant all required permissions automatically and thus fail to sync the contacts locally.



Hi @weberda @Sameer1884,


I have also found setting to Prompt can cause this issue, the problem can occur on any MDM platform and seems to happen to Android ~7-8 devices.


Change the Default app permissions to default, this will have the same impact as prompt without defining the setting.


Any application that requires Auto Grant will have to be setup using App Config under Client apps > App configuration policies. More information can be found here;



Hi Thank you Andrew and Daniel I will test with both your setting ans leave a feedback.




Hi Andrew

When you say set permissions to "Default" , do you mean to say remove all permissions set on the policy for app configuration?


Or add all permissions?


Currently I have these:

permissions contact1.jpg

permissions contact2.png





My problem is resolved.


there is a 3rd permission for contacts that needed to be added on top of Read and Write: Get Accounts





Thanks a lot. I had the same problem and applied your settings and it worked 


Hi No Problem. Glad I could help. It did make me waste a lot of time trying to get this sorted. :)

Yup, u r right, initially we had same issue which got resolved by changing the settings to “prompt” instead auto grant

It works for me.:smiling_face_with_smiling_eyes:
Hi Sameer,

I tried the same thing and this doesn't work for me. I don't even see the SYnc Contacts option in the Outlook app inside work profile. What could I be doing wrong here? Please advise

@Prasad1855 Hi, do you have "Add and remove accounts" blocked in your device restriction profile?

Maybe this is blocking you from enabling the contacts sync as it has to create an account within the work profile?

It was not appearing for me too because it seems the policy was not updated on the Device work profile. I tried to sync the device in Company portal manually and waited 2 hrs. It would appear after that.
Check if the policy is apply to the correct user/group as well

@Durrante , I've h ad the same problem. Carrying over my configuration to me it worked:


I don't know if anyone could use it.