Shared Forms no longer loading in iOS 10.3.3 Safari

Brass Contributor

As of Thursday, October 24th, Forms that have been previously shared with my students no longer load on our classroom iPads. We see the green spinning dots and the word "Loading...", but the Form(s) never fully load.


I'm running around 240 iPad 4s in my classroom, and the highest iOS we can run on them is 10.3.3. I've tried everything on my end, resetting the device, deleting the cache, deleting cookies, everything, but nothing works.


I'm able to visit I'm able to load up a Form for editing, but opening up a Form via a shared link (set for either anonymous and organizational login) does not load at all anymore.


Please fix this! I use Forms for a lot of assessment and data capture with my classroom students, but we only have access to iPads running 10.3.3.



16 Replies

@Zhongzhong Li - Does your team have any response to this issue? My students need to continue using our assessment form today, I would like to stay away from having to use Google Forms, seeing that it would split up my data.

@Andrew Fitzgerald 

No solution, but following/replying so that I can get notification if someone replies, as we find ourselves in a similar situation.

Bump! Because I'd rather not use Google Forms anymore.


Any response to this issue MS Forms team?

@Andrew FitzgeraldExactly same issue here with iOS 9.3.5. Stops at the message "Loading..." and never loads.


Any action done was unsuccesfull: Cleaning cache, cleaning data of specific domains, resetting the table and.


Waiting for the MS team...

@solucionesdfhaving same issue. Any suggestions? Any response from MS support about this yet?

@IrfanAli I'm having this same issue too on the new iOS on the Sharepoint App. It always hangs at this screen, regardless if I'm on data or Wifi.



@Andrew Fitzgerald I used my 4th Generation iPads with Forms a couple of weeks ago, but now they no longer work.  I have even tried taking the long link and making it a bitly link.  Then I went into Safari with the shorter link, but it still would not work.  It did the same thing.  It would get to the point saying it was loading, then just circle.

@Andrew Fitzgerald this issue does not reproduce on later versions of iOS, but unfortunately that requires newer iPads.  Do you have the option of trying another browser on the device?  Can you try Chrome?


Thanks everyone for raising this issue



Program Manager - Forms

Hi @Jon_Kay, thanks for the response.

On my school iPads we also have the Chrome app, and it also shows the same issue. Maybe the issue is related to iOS 10.3.3's version of webkit?

@Andrew Fitzgerald ah, good point.  Thanks for testing it out and looping back.  We've opened a bug to track this issue on our side, but I cant give high hopes of addressing it in short term.  Given the age of the devices and limited support from Apple (cant upgrade to latest iOS), +limited usage, it is lower on the priority list compared to other work items. 


We are getting a device now to test.  I am wondering if there is a setting that you can enable/disable to workaround this.  There are a bunch of settings within: Settings->Safari->Advanced->Experimental features, but i cannot tell you which to test out yet.  After we get device to reproduce locally, I am hoping i can give you more insight.  In the meantime, if you do trial/error and happen to get through, please let me know. 

@Andrew Fitzgerald  sadly it seems that the safari experimental menu is also not available in ios 10!  it was added in ios 11. 


I have had the exact same issue on 2 iPad devices at my organization. It doesn't matter which browser we use, it still doesn't fix the issue with Forms. Downloaded Edge browser and still ran into the same problems.

@Jon_Kay Any update on this issue? I still have 4 more months in this school year and would like to avoid switching over to Google for all my classroom Forms.

@Andrew Fitzgerald I have received zero help from Microsoft and Apple.  I am thinking the problem is stemming from an update to Forms.  I have switched to new iPads and/or using a tinyurl for my students to login to my tests.


@Andrew Fitzgerald Apologies, no further updates from my side.  

The issue is back using iPadOS 15.5 @Jon_Kay