MS Forms is failing to save changes and new form information

Copper Contributor

Across our organization we are experiencing an issue where MS Forms is not saving any changes or maybe a handful out of many to a forms and not saving new forms (saves as untitled with no content).  Is anyone else experiencing this issue?  We rely heavily on forms and may need to find another platform if not resolved soon!

13 Replies

@Cristina_Diaz  Sadly this is still occurring within the Microsoft Forms. I spent about an hour creating a form and when I went to show it to someone, I found out that only about half of my work had saved. Very disappointing. I don't think I'll be able to use this tool since the autosave is unreliable and there is no manual save option. 

@kwbutler I have same problem too

@ have the same problem

Is any solution from Office already available?
Can we trigger manually somehow the "auto-save" ?
Having same problem (part of changes unsaved), and tricky to follow using the tool...



I've just recently started using MS Forms and the first couple of surveys I did were fine. However, I have suddenly started to experience this issue as well. I strangely also kept getting a message asking if I wanted to remain on the page or leave, which I presume is part of the same issue. I read another post from some time ago suggesting that refreshing after adding every question sorts this issue. However, that isn't very convenient. Also, that post was from 2017 and this issue is still not solved!

@HannahH12 I am experiencing the same issue. It's infuriating! 



Me too. It is frustrating


Someone at Microsoft Forms development team is taking care of this issue?

I have the exact same issue. After 8mths of using MS Forms with no problems, I spend over 2 hours working with my customer on a form only for the save to fail and lose more than half the information. Noticeably I was also constantly getting the “Leave the page” message popping up which I’ve never had before. The auto save was saying “saving” & “saved” constantly. I have noticed that forms has changed recently in its layout and wonder if these changes are the cause
Same problem here, anyone knows what occurs? We make some corrections in Forms and some save, some not... this a bug with Office forms?
I too am getting this on specific forms, you just have to sit there randomly changing fields to trigger a save and hope that it's successful. Very Infuriating.
Hi, while we have the same problem here, we test diminish the number of characters per question. Office forms have this limits of characters by questions, answers etc...
I.E one question have a great number of characters, we divide in two questions, and works!

Anyway: Office forms don´t display a message of this limit, but display "saving" while you type.. and "saved" when you not type.

Need to improve this.

I just experienced this issue exactly as described here@Cristina_Diaz !  August 2021 for Pete's sake!


I was having the same issue, but I think I've solved it for now. I went back to edit my missing questions, then copied the "edited" question,  then added it as a duplicate question. I shared the Form in our Team channel and sure enough both the "edited" and "duplicate" questions appeared on the Form. I went back to Form, and deleted the "edited" question, which should be above the "duplicate". Shared the link again and my Form is now corrected. I've only tried it with one form but hope this solves the problem for now. Hope this helps.