Can't find forms

Copper Contributor

I opened Forms today and there is a new layout. It showed where my forms are in My Groups, which was useful. At first, it also showed me all of my quizzes and forms that I had made recently at the top. After making a new form, I returned to the main Forms page. Now it only shows me My Groups and not the most recently made quizzes or forms. Unfortunately the form that I just made does not show up in an of My Groups. Therefore, I can't edit or see the results for that new form. How can I see the recently made forms or even all of my forms?

21 Replies

@akean1415 An update: I can see my recent files on my iMac. I tried rebooting my Macbook Pro to see if I could see my recent forms, but I still can't. I don't know if it has something to do with the screen size. It's very frustrating.

@akean1415 can you share the machine type, and which browser you are using? 

@CJZheng Hello - I'm having the same issue. We used to have 2 different views - when you go to the portal, your Forms looked different but when you go to Forms directly then you would have more options to view things which was great. Now you can't even copy a Form from one group to another the way the layout is set up. 

I'm using a PC and using Chrome as the browser.




Same situation here.

Doesn't matter which browser I use.

@Jessica Stepaniak 

I have the same problem - only see Group Forms, but cannot find my personal forms anywhere. It started last week, then when logging back in I could see my forms again - but now they're gone again and I can only see the Group Forms. No way to find my personal forms, not linked to any group.

@akean1415  I just found this on another Forum..
You've still got the move & copy options: click All My Forms at the bottom of the page. The screen that appears looks exactly the same but has one key additional ingredient which is that now, when you click the 3 dots next to each form, you get the copy and move options.



I have the same issue. I assume all my older forms are still out there somewhere but no way to get back at them...

@bschaerlaekensSame issue here. Wasting my time to find forms.

@akean1415 I have written a blog post on this and here is the workaround.

@jay_singh thanks a lot, this does the trick!

@jay_singh Thanks for your workaround! We are investigating the root cause, and the fix should be live soon. BTW, have you tried to new a form by clicking the button. did it help?

@CJZheng New form takes the user to the new form page. It does not help.

We already deployed the fix hours ago. Can you help me to check if you can see the “all my forms” entry? If so, can you see the most recent used forms?
We have a fix recently, can you help to check if it fix your issue? Can you upload another screenshot after the fix deployed?
@CJZheng Works for me now, thanks!
Not fixed for me unfortunately - the problem was gone for a couple of weeks, but is back again now. I can create new forms, no problem, but cannot find my existing ones (except for my GRP-forms, and I don't have any interest in those). thanks
Thanks, that helped!
Sorry to hear that, can you provide with a screenshot about the current UX.

Here's the screenshot, thanks!