Bug in branching

New Contributor

There seems to be a bug in the branching.  In the attached video question #9 (00:34) mis-registers the radio option click and displays the wrong question as #10 according to branching logic (00:40).  If the user re-clicks the radio button in question #9 the correct branching occurs and the right #10 question appears.

This will likely confuse the hell out of people.  I tested this survey a few weeks ago and everything worked fine.  I reset and redid all the branching to see if that would fix it but to no avail.  Also tried different browsers and in icognito mode as well.

I'm hoping to go live next week.  Would really like to see this fixed or I'll have to move the survey to another platform.

1 Reply

OK it seems this may have been an isolated case.  I duplicated the form using the "share as a template" feature and the problem followed with it.  However, I painstakingly manually recreated the form as a new one and the problem isn't there.

 

Here's hoping the bug doesn't suddenly appear later on.  Crossing my fingers.