Visio files saved in OneDrive cause UPLOAD BLOCKED error

Brass Contributor

I have two Dell computers – a laptop at work and a micro form factor device at home.


I’m using OneDrive with O365 so that I can work in either location without lugging  a laptop around.


I create a brand new, blank Visio file on the laptop at work, insert some content, then Save As with a new file name on the OneDrive.


I make sure the blue cloud in the system tray says all files are synchronised, shut down and head home.


I open the recently created Visio file on the home MFF PC.


I get an error immediately saying “UPLOAD BLOCKED We ran into a problem with this file and can’t save any new changes. Please save a copy to avoid using your work”.


Always happens with Visio – it has happened with Word and Excel but not every time like with Visio.


The same happens in reverse, i.e., a new file created on the home MFF PC and opened later in the office.


Both PCs are running up to date windows and the Visio apps are same version on both PCs.


I created a new file in the browser-based version of Visio – same error on both home and work PCs.


I have reverted to using just the laptop, storing files on the local SSD, backing up every day.


Any advice would be welcome.

Thank you.









38 Replies

@Penrynian I'm seeing the same issue very frequently at the moment, whereas it would be rare usually. My more common issue used to be the Visio file becoming read-only. I'm hoping that if enough people report this, then perhaps we have evidence for Microsoft to take action.


This has been happening to our users as well.


One PC has Visio Standard 2016 and cannot sync or upload .VSDX files to SharePoint or OneDrive.


One PC has Visio Standard 2019 and cannot sync or upload .VSDX files to SharePoint or OneDrive.


Microsoft needs to fix this.

@Chuck Alexander  What makes you say that UK users are not affected?  I just looked out the window and all the cars appear to be driving on the left hand side of the road .....


Most odd I woke up this morning, with a burning question mark over Obamacare. Fixing this issue seems so much more straight forward than that surely? #UKO365LivesMatterToo

@Paul_Mead  One would think so Paul :) 

Ha! I just thought UK users were not affected because my supervisor in the UK was not experiencing the issue.

Of course all Visio users worldwide who are affected should be fixed :smiling_face_with_smiling_eyes:.

I hope Microsoft fixes it soon.

@Chuck Alexander Ah, that makes sense!

The support company I use hasn't heard of this situation, and I would say they're usually quite up to speed with Microsoft issues.

I wonder just how widespread this is.


I raised a support case with Microsoft; the chap I am speaking with has managed to recreate the problem in his test lab. 

Just waiting to see the outcome, I'll share here once known.

@Penrynian Just popping in for a "Me Too"


Hopefully MS sorts this shortly



Same problem here. Started end 2020. 


It really is annoying. Have to save my visio's to a new file every time i open them.  

@Chuck Alexander I can confirm that I'm seeing the same issues as well.

@Penrynian Did you end up hearing back from Microsoft on this one? :thinking_face:

@ParryFen@Penrynian , I'm just chiming in with a me too as well from Australia. in my instance my account has a visio plan 2 license. also cropped up incidentally around the end of last year, but I only realised it's a persistent issue today.  things I've excluded/looked at in my testing:


- not a sign-in/sign-out issue. removing re-adding onedrive or sharepoint accounts makes no difference

- not a software update issue (stable release , updated to 2101)

- the problem happens whether I access a file via Link to online sharepoint, or directly on disk, pointing to the local copy of the vsdx file.

- in my instance, I don't think I've ever loaded this file on any other system, (made myself, not shared with others) so I don't think it's a sharing issue.

- during one test cycle, I got a security prompt from Visio before opening the file using a direct sharepoint link, so I'm wondering if there's a a permissions or security issue underlying this...

@armen-iptel, I've had this same problem on and off since I started using Visio Plan 2, currently v2101. I access files through Sharepoint with a local sync to File Explorer. I had the error opening the local copy. I also logged into O365 and opened it in the browser and then chose to open the file with the desktop app from there. Same error. I closed Visio and clicked "free up space" on the context menu in file explorer to delete the local copy. Then I double clicked the cloud copy which opened in the desktop app and, this time, no error.

@siuc_me Just tried that and it did not work for me

Currently have users in my organisation that are getting this issue as well. I did do some google-fu and found this exact issue here:

I have also raised this issue as a ticket with an O365 support tech - will post the outcome of that here (If they found anything different/do find a fix)

Has anyone attempted a reinstall of visio? I got one of my users to do this, and Visio was working as expected, however this was short lived - only lasted a week!

Thanks for your input @Anas_Hussain 

I have a call later today (24th) with the MS support person who is looking into this.

I'll update this thread afterwards.

You referred to another thread from 2018, it made me think I have the same issue.

I used to have a VERY old version of Visio, I think it was 2003-2010.

I uninstalled it when I got the new Visio Pro as an add-on to O365.

I'm wondering if this is the root cause and reinstalling it may help.

Mmmmm :)


Did you hear back from MS about this one? :)