Teams error code - 6

Occasional Contributor



One of our user have an issue when he try to connect to the Teams applications, here is the error messages:




The user is able to connect to Teams online with no error message


Can you help me with this?

18 Replies
Assume they have tried signing out and back in? That will clear any local cache issues.

@Chris Webb  I solved the issue, it was caused because of a misconfigured group, but thanks for your answer

best response confirmed by damnit95 (Occasional Contributor)

@damnit95 May I know what was the issue, I am also having the same with one of my user

@VijprateekCheck the user group differences between one of your users for which it is working in your pwa settings on your sharepoint site

@damnit95 , We have a user that is experiencing this issue as well and is unable to log back in from the desktop application while web continues to work. After uninstallation and reinstallation of the latest image, there is initial success followed by a return to the same error after the user logs out of W10 (for lunch or end of day) and a reinstallation is required again in order to use desktop. User reports online and mobile working consistently during this time. Any thoughts?

Hello all I know this is an old thread but I am having this issue but for multiple users. They have tried uninstalling and reinstalling, clearing cache. etc @damnit95 

@damnit95 Hi, is ther eany chance you could expand on this,  We have endured a rapid adoption of teams due to Covid and have not entered full support yet so the project is trying to resolve this issue which seems to happen mostly when offsite.

No worries I went had and opened a case@Kieran99 

For me, I uninstalled TEAMS and removed all the related files of TEAMS from Appdata, installed TEAMS again and it solved the issue... @damnit95 

@damnit95 Old thread but might be able to help out other users;


OK, I've been having the same issues with users for weeks now and it was driving me crazy. I finally found a solution.


1. Close Teams

2. Remove all Cached Data as described by Betty Gui

3. This was our magic step - Make sure there are no weird proxy settings running. Either in the Windows Settings -> Proxy or through Internet Explorer -> Internet Options -> Connections (even if you don't use it anymore, like us). Make sure for all proxy settings you have "Use a proxy server" to off and enable "Automatically detect settings". 

4. Make sure your user is connected to "vanilla internet" - so no VPN or whatever (important for the first time login, otherwise it still doesn't work)

5. Open Teams and now it should work


After this, for our users we could reconnect to a VPN connection.


It seems that the error here is caused by a Proxy running over a regular ethernet or WiFi line.

We were able to identify this as we had some users in just 1 country with this issue, and some of them had very old proxy settings still enabled.

The "error 6" error is commonly caused by incorrectly configured system settings or irregular entries in the Windows registry. This error may be fixed with special software that repairs the registry and tunes up system settings to restore stability @damnit95 

@damnit95what a group ? could you please give Me the steps troubleshooting. Thanks before.

@SamK50 Hello, I would like to know what procedures you performed to correct this error code 6 problem. In my case Teams is used in an educational institution, with a network domain fixed on the computers. Thankz

@robsonguimaraeshere is a script to clrea TEams cache maybe it will solved your issue



start-transcript "C:\temp\ClearTeamsCache.log"

# get Teams process
$Teams = Get-Process Teams -ErrorAction SilentlyContinue
if ($Teams) {
do {
$Teams | Stop-Process -Force
}while (!$Teams.HasExited)


#Remove-Item "$env:appdata\Microsoft\teams\application cache\cache\*" -Recurse
Remove-Item "C:\Users\*\AppData\Roaming\Microsoft\teams\blob_storage\*" -Recurse
Remove-Item "C:\Users\*\AppData\Roaming\Microsoft\teams\Cache\*" -Recurse
Remove-Item "C:\Users\*\AppData\Roaming\Microsoft\teams\databases\*" -Recurse
Remove-Item "C:\Users\*\AppData\Roaming\Microsoft\teams\GPUcache\*" -Recurse
Remove-Item "C:\U*\*\AppData\Roaming\Microsoft\teams\IndexedDB\*.ldb" -Recurse
Remove-Item "C:\Users\*\AppData\Roaming\Microsoft\teams\Local Storage\*" -Recurse
Remove-Item "C:\Users\*\AppData\Roaming\Microsoft\teams\tmp\*" -Recurse
Write-Host "Failed"

hello, i still cannot sign in to teams (i signed out and signed in like a hundred times)

@damnit9530 Thanks for the guidance, but I decided otherwise. In the internet options accessing through the internet explorer browser, I went to the "advanced" tab, and in the list of settings that appears, unchecked the options "check for signatures in downloaded programs", and "check for revoked certificates from the supplier" more at the end of this list, and clicked OK to save the change. Since I use Teams in a firewall-controlled environment, these options probably block your access. Sorted out!

@damnit95Edge is required to run TEAMS on W7.

@robsonguimaraes Check the computer's date and time settings.