Privacy option infinite loop

Copper Contributor

I have a problem that has just started with all Office 365 Apps.
1. I start the app, e.g. Outlook.
2. A privacy popup appears asking me if I want to send optional data or personalise my experience.
3. I select no to both options & click next
4. I get a message saying that I need to restart Office to apply the Privacy changes? What changes?
5. So I close Outlook. No other Office apps are running. Go back to step 1!

 

This goes on forever. I just want to turn these option off. The fact that Office needs a restart suggests to me that these options are on by default & currently I cannot actually turn them off! 

5 Replies

@keith2235 

 

Try this:

 

1. Open an Office app, e.g. Excel
2. Click File > Options
3. From the Options > click Trust Center
4. Click Trust Center Settings
5. The next Window should select Privacy Options
6. Click Privacy Settings
7. Uncheck "Turn ON optional connected experiences" box
8. Click Ok

@Kidd_Ip Thanks for that. The trouble is that when I open Excel, the very first thing that pops up is the "Microsoft Respects Your Privacy" popup:

Screenshot 2023-09-16 121148.png

I can't click on options or anything else at all, until I have completed the Privacy dialogue. At the and of the dialogue, I'm told that a restart is required. If I ignore that & try to go through the options that you suggest, when I get to the part when I click on "Privacy settings...", I just get a pop up stating that a restart is required! So I can't actually get into the privacy options to change them!

Screenshot 2023-09-16 120721.png

I have the exact same problem. I tried to re-install Office 365. It worked for a couple of days and then went into this "Privacy option infinite loop" again.

 

This is my installed version:

DocJamesDK_0-1695718714700.png

 

I found a workaround, which works for me. I started Excel and logged out of all my Microsoft accounts in the top right corner. Now I can start the office applications without the privacy loop. I might be forced to log in again for Office to check my license.

It will not work, if you need to be logged in to your Microsoft account.

Thanks for your response and apologies for the delayed reply, I've been away.
I never got a chance to try out your workaround, because for me, the problem seems to have gone away!
I have not knowingly changed any settings.
I did however run Windows update a few days ago.