O365 activation issue - Microsoft.AAD.BrokerPlugin.exe crash

Copper Contributor

We are having issue activating O365 on a 2019 RDS Server.

We have deployed following using the deployment tool as per this procedure and everything went ok, except that whenever an user wants to launch an app they are prompted to activate with their account. They enter the username then a blank window pops up for a few second and disappears. No error reported ... but no activation.


Looking into %localappdata%\Microsoft\Office\16.0\Licensing we see that there was no token generated.


Looking into the event log we can correlate this with a crash of Microsoft.AAD.BrokerPlugin.exe





Log Name:      Application

Source:        Application Error

Date:          15/03/2021 20:34:28

Event ID:      1000

Task Category: (100)

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      rd-dn-01.domain.local


Faulting application name: Microsoft.AAD.BrokerPlugin.exe, version: 10.0.17763.529, time stamp: 0x5cde4ed1

Faulting module name: edgehtml.dll, version: 11.0.17763.1817, time stamp: 0x409d5916

Exception code: 0x8000ffff

Fault offset: 0x00000000004b5ab6

Faulting process id: 0x19f0

Faulting application start time: 0x01d719d23699f2e6

Faulting application path: C:\Windows\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Microsoft.AAD.BrokerPlugin.exe

Faulting module path: C:\Windows\SYSTEM32\edgehtml.dll

Report Id: d1e78a5d-2dcd-4313-b547-c41eefe64980

Faulting package full name: Microsoft.AAD.BrokerPlugin_1000.17763.1.0_neutral_neutral_cw5n1h2txyewy

Faulting package-relative application ID: App

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">


    <Provider Name="Application Error" />

    <EventID Qualifiers="0">1000</EventID>




    <TimeCreated SystemTime="2021-03-15T19:34:28.839239700Z" />




    <Security />
























I have opened a ticket with support but they are completely useless – hardly managed to schedule a call-back within a week. We've run usual t-shooting (sfc, dism, desintall-reinstall, etc).


Tried to follow this and this but did not help.


At this stage we are pretty much stumped and unable to use or 365 subscription for a week.

3 Replies

Hey @alexTak ,


Couple of things you can try, update the .NET framework on the machine, try downloading the office via ODT on a different channel; semi-annual may be. Most importantly look at your firewall add an exception for :



Take a look at this: https://docs.microsoft.com/en-us/office365/troubleshoot/authentication/connection-issue-when-sign-in...



Knowing this is a very old blog, but we are seeing now the exact same issue. Was this ever solved and are you able to provide the solution?

Yes we did... but it took 2 weeks, escalation to level 2 than level 3 (or whatever they call it).
They gave us all kind of registry entries (sorry... I lost count) that eventually turned off many "smart features" and allowed us to activate.
So I'm afraid you will have to go with MS Support (they are pretty good IF you have the patience - I'm afraid you will be in for quite the trip)