Can't get office Updates

Copper Contributor

A few weeks ago, I had Office 365 ProPlus with the recent updates installed and I was be able to download the updates. After I executed the repair options, Office back to Version 1808 (Build 10730.20348) and now when I try to get Office Updates it shows the message "Updates are managed by your system administrator".  I have tried to repair again but I didn't work.


Can anyone help me?


Thanks in advance.

10 Replies



Is your machine a domain joint machine?

Any group policy settings in your organisation which disables the automatic updates?


If your machine is not domain joint, have the temp files cleared, restart your machine and try to update it again.



Thank you





My computer is a joint domain machine, but other colleagues can get the office updates and a month ago, I was be able to download the updates whenever I wanted.


I cleared C:\Users\...\AppData\Local\Temp and C:\Windows\temp and I restarted the machine, but the problem persists.


Maybe there are some registry settings blocking the updates?


Thanks for all.


best response confirmed by Oscar_Verdugo (Copper Contributor)




Are your colleagues using the exact version and build of the office client software on their machine?


Please try repairing Office package using Office Repair tools and let us know the result. 

Perform a reboot after repair.


If it still does not work then I reccommend you to remove office and insall it from the Office365 portal via "Install Office" option.


Thank you


Hi @Oscar_Verdugo, the message "managed by your system administrator" implied that Office is managed through SCCM on your device. So the admins in your organization are on control when and which update your device gets. There is no way you can bypass this.


According to the release notes you are running the most recent update from the SAC update channel, so it seems that everything works as expected (and configured by your admins). If you want to be on a build with more features, you would have to reahc out to your admins and ask them to switch you to Monthly Channel.

Hello @Deleted.


I removed all the Office Components and reinstalled and now I have a more recent version (1902-Build 11328.20368) and I have the Update option available.


It seems the problem was the Visio 2016.


Thanks for all.

Hey, I realize this post is 5 months old, but I have the exact same issue, and having a lot of trouble finding any resources or posts about it! Did you ever find a fix?

Edit: Nevermind, I disabled the metered connection kodi lucky patcher nox  setting and it updated just fine. Weird that it didn't work even when agreeing to update on a metered connection.

@Oscar_Verdugo Browse to -> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration\OfficeMgmtCOM=TRUE
Change OfficeMgmtCOM
Open Word and update now should work.

@RaghuKeenLearner worked like a charm thanks

@RaghuKeenLearner That path doesn't exist on my domain system.

But when I browse through this path I see this


@Ugodspecial make  Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\office\16.0\Common\officeupdate\OfficeMgmtCOM=0. it should work