Utiliser la bonne formule

New Contributor

Bonjour,
J'ai besoin la valeur dans la colonne B détermine automatiquement la colonne C et la colonne D avec des informations présentes dans l'onglet "DONNEES". 

Onglet "PRICE LIST"

 BCD
1Price ValidityOUT / Pax req.IN / Pax req. 
2Any Date-CDG/SFJ--
317/05-CDG/LYR-T174171
4>200...  


Onglet "DONNEES" 

 

 JKL
1Validation TableOUT / Pax req.IN / Pax req. 
2Any Date-CDG/LYR--
3Any Date-CDG/SFJ--
417/05-CDG/LYR-T174171

5 > 36

...

  


J'ai créé la formule ci-dessous mais elle ne fonctionne pas. 

=SI.CONDITIONS([@[Price Validity]]=Données!J2; Données!K2; [@[Price Validity]]=Données!J3; Données!K3; [@[Price Validity]]=Données!J4;Données!K4; [@[Price Validity]]=Données!J5; Données!K5; [@[Price Validity]]=Données!J6; Données!K6; [@[Price Validity]]=Données!J7; Données!K7; [@[Price Validity]]=Données!J8; Données!K8;[@[Price Validity]]=Données!J9; Données!K9;[@[Price Validity]]=Données!J10; Données!K10;[@[Price Validity]]=Données!J11; Données!K11;[@[Price Validity]]=Données!J12; Données!K12;[@[Price Validity]]=Données!J13; Données!K13;[@[Price Validity]]=Données!J14; Données!K14;[@[Price Validity]]=Données!J15; Données!K15;[@[Price Validity]]=Données!J16; Données!K16;[@[Price Validity]]=Données!J17; Données!K17;[@[Price Validity]]=Données!J18; Données!K18;[@[Price Validity]]=Données!J19; Données!K19;[@[Price Validity]]=Données!J20; Données!K20;[@[Price Validity]]=Données!J21; Données!K21;[@[Price Validity]]=Données!J22; Données!K22;[@[Price Validity]]=Données!J23; Données!K23;[@[Price Validity]]=Données!J24; Données!K24;[@[Price Validity]]=Données!J25; Données!K25;[@[Price Validity]]=Données!J26; Données!K26;[@[Price Validity]]=Données!J27; Données!K27;[@[Price Validity]]=Données!J28; Données!K28;[@[Price Validity]]=Données!J29; Données!K29;[@[Price Validity]]=Données!J30; Données!K30;[@[Price Validity]]=Données!J31; Données!K31;[@[Price Validity]]=Données!J32; Données!K32;[@[Price Validity]]=Données!J33; Données!K33;[@[Price Validity]]=Données!J34; Données!K34;[@[Price Validity]]=Données!J35; Données!K35;[@[Price Validity]]=Données!J36; Données!K36;[@[Price Validity]]=Données!J37; Données!K37;[@[Price Validity]]=Données!J38; Données!K38;[@[Price Validity]]=Données!J39; Données!K39;[@[Price Validity]]=Données!J40; Données!K40)


4 Replies

@BenSwiss1007 

Dans K2:

 

=SIERREUR(INDEX(DONNEES!K$2:K$40 EQUIV($B2; DONNEES!$J$2:$J$40; 0)); "")

 

Remplissez vers L2, puis remplissez jusqu'à la ligne 200.

hey @Hans Vogelaar 

ça ne fonctionne pas.

 

Dans le tab "Price List", je choisis manuellement la valeur de la colonne B. Selon cette valeur, la colonne C et la D font chercher la correspondance dans le tab "Données".

 

Merci pour ton aide. 

 

PS: Je t'enverrai bien des captures d'écran mais je n'ai pas la permission

@BenSwiss1007 

Voir le fichier:

Merci @Hans Vogelaar ça fonctionne très bien