Spacebar not working inside Cells in Excel

Copper Contributor

Hello, I’m using macOS Monterey Version 12.1, Microsoft Excel for Mac Version 16.56. The spacebar stopped working in Excel when I’m typing inside a cell. It only works if I press “Shift + space” or “Option + Space”. Otherwise, it works as a tab key, moving around the file. How can I solve this issue? I have tried to find a solution online but haven’t found one yet. Thanks!

19 Replies

I have the same problem, before I seen your comments, I didn't know I could shift+space or option+space, I'm just excited I can now at least do that!

Hope there is a fix, but for now, I can shift+space! @Sara_DelValle 

I have the same issue. Thanks for the shift + space suggestion.
I have the same problem, how fix it?
Click Apple menu, go to System Preferences> Accessibility> Keyboard> Navigation, check if Full Keyboard Access is selected (enabled). If it is, uncheck it to disable.
In case you do not want to unselect/disable Full Keyboard Access feature to use other shortcuts, click this option and go to Commands and clear Spacebar option.


This worked and thank you so much.  No one else in the world could help me, I have spent hours and hours trying to figure this out.  

Thanks agan!@novalx 

@novalx thank you so much for this suggestion! I was just about to give up but It worked!


hola he probado lo que sugeris y continuo con el problema 

Anyone with a fix please let email address removed for privacy reasons know. Does anyone know how to get to site that send instructions for common problems, esp. how to link LG keyboards to iMacs?
Thanks Sara.

@Great solution. thanks


great solution, thanks
Thank you, it worked well

@cjinnome Thanks for sharing, I had no clue there was a work around 

just try switching off the keyboard access.


@novalx That worked! Thanks, this happened on its own some time last week. So weird. 

thanks its working now

Thanks it is working now@novalx 

I cannot believe that I fought with this issue for so long! Totally appreciate this fix!! It worked!