Sharepoint.files : Date Modified = Error

%3CLINGO-SUB%20id%3D%22lingo-sub-1690795%22%20slang%3D%22fr-FR%22%3ESharepoint.files%3A%20Date%20Modified%20-%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1690795%22%20slang%3D%22fr-FR%22%3E%3CP%3EWhen%20I%20access%20a%20Sharepoint%20file%20list%20with%20API-15.%20The%20%22Date%20Modified%22%20column%20has%20lines%20that%20are%20misadding.%20Dates%20that%20are%20not%20misleaded%20are%20wrong%20(the%20month%20is%20in%20the%20place%20of%20the%20day%3A%20%20)%20and%20seem%20to%20come%20from%20a%20data%20source%20of%20the%20international%20English%20type.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWith%20the%20API-14%2C%20I%20have%20the%20right%20data%20in%20PowerQuery%20but%20the%20response%20times%20are%20very%20long%20and%20the%20loading%20in%20Excel%20never%20succeeds.%20I%20have%20an%20error%20message%20(500).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ptripier_0-1600685856550.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F220124i315286BAD9407811%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22ptripier_0-1600685856550.png%22%20alt%3D%22ptripier_0-1600685856550.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EDo%20you%20have%20an%20idea%20to%20solve%20this%20problem%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1690795%22%20slang%3D%22fr-FR%22%3E%3CLINGO-LABEL%3EBI%20-%20Data%20Analysis%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Visitor

Quand j'accède à une liste de fichier Sharepoint avec API=15. La colonne "Date Modified" comporte des lignes en erreur. Les dates qui ne sont pas en erreur sont erronées (le mois est à la place du jour ) et semblent interprétées comme venant d'une source de donnée de type Anglais international.

 

Avec l'API=14, j'ai bien les bonnes données dans PowerQuery mais les temps de réponse sont très long et le chargement dans Excel n'aboutit jamais. J'ai un message d'erreur (500).

 

ptripier_0-1600685856550.png

Avez-vous une idée pour résoudre ce problème?

 

0 Replies