Excel macros blocked even with the file location listed in Trusted Locations. How to fix it please

New Contributor

Hi.

Can anyone tell me why my macros stopped working weeks after a Group Policy was implemented to block them ?

EVEN after:

- Listing the locations in Trusted Locations

- Repairing Office

- Making another group policy to add a trusted location

- Moving the file to existing trusted locations

Not even a warning that the macros are stopped, until I actually try and run it

Better still - how can it be fixed ?

2 Replies

@Hardy100 

First of all, if I may recommend it, inform us about the digital environment. Excel version, operating system, storage medium (hard drive, One-Drive, Sharepoint, etc.).

All of this would be beneficial for you, so you get a solution that fits your project/problem much faster and more precisely. Welcome to your Excel discussion space!

 

Additionally... the problem appears only with a certain file or with all files?

...only at a specific location?

...only with .slsm files or also with .slsx?

…which macros are enable/involved?

 

At the same time, I always recommend (even if I don't have any of the information above) to carry out an update in advance.

Since you have already performed an Office repair, the next step would be to disable all macros, reboot, test, and if the problem resolves, re-enable the macros one by one.

If that doesn't help either, you could do a safe mode start.

 

If this does not help either, here is a link with possible sources of error.

 

 

I would be happy to know if I could help.

 

NikolinoDE

I know I don't know anything (Socrates)

Thanks for your Reply NikolinoDE
The problem seems limited to certain computers.
I can use my desktop in the office with the same files and its no problem.
I've had other users in my company with the same issue (initially). Added trusted locations for them. Macros not working initially after after an hour or so it comes good.
File location doesn't seem to matter. I've tried C:, Shared drives, Sharepoint. The original file lives in sharepoint but I always run the macros after opening the XL from the local synced folder.

Running Win 10 enterprise, V1909, build 18363.2037. 64 bit Office 365 MSO (16.0.14326.20702) 32 bit.
I should add that these macros were working ok last week and then late lastweek I had two reboot for patches. Hasn't worked since.
I may be able to remove these and try again.
Just did some further tests
- a database full of VBScript had no issues.
- Excel - recorded macro in a new sheet, runs ok
- Recorded a macro in the 'faulty sheet' runs ok (stepping through it)
- The problem macro, I can step into or run it from the VB interface
- Buttons linked to the same macro bring up the error as before - macro not available or not enabled
- Relinked the button to the macro, Still get the error.
So maybe the macro is not disabled, maybe there's a problem in the link.
- Create new XL file. Record a macro. Test Macro from macro list - Works ok.
- Put shape onto the page and link to the macro. Click on shape and same error message. Macro not available or macros disabled.
- Open Macro menu and run directly - macro works ok.
So definitely seems there's an issue to run macros from a linked shape.
- Repeat above in safe mode - same result.
xlsx/xlsm doesn't make any difference (except that macros aren't saved in the xlsx file)
Occurs in unsaved files too.
The "possible sources of error' link doesn't seem helpful either.
Any other suggestions ?