Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'.

Copper Contributor



I need to use the solver add-in for my studies. However, Every time I try to use it I get an error: "Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'. The macro may not be avaliable in this workbook or all macros may be disabled."


Even if I uninstalled Office products on my PC, the error was not solved.


I will be glad if you solve this problem.



20 Replies
Has anyone helped to solve this issue?
My exams are approaching and I still haven't solved this issue, have tried to re-install 4 times already, nothing is changing.

I am not used to use "Solver.xlam" but it is related to add-ins. You may go to Option --> Add-Ins to see if it is enabled or not. 

Thank you for trying to solve it, but it the error actually appear after add-in is enabled (through options like you say) and after you try to use it (press on solvers button) it shows an error "Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'. The macro may not be available in this workbook or all macros may be disabled."
best response confirmed by cuong (Microsoft)

I've recently encountered a similar issue with Solver. Uninstalling and installing office 365 did not work. The issue I think was caused by 32bit vs 64bit incompatibility yet when I checked office, windows, and my laptop they were all 64bit. Then once, when I was uninstalling MS office I noticed that there was another office app that came with my laptop called "WPS Office" which is freeware shipped with Asus. Since I was not using it, I decided to uninstall it. And voila that made solver work again.

@DavidDodd888 Thank you so much, after unistalling "WPS office" (that I never installed, because it came with my windows), Solver is working again!!!
I had installed 3 different versions of office and then I decided to reset my windows. Nothing worked.
Unistalling WPS office is the solution !!!!

@DavidDodd888thank you so much your the best!

You my friend have saved my life! Thank you for this!
I've wasted a day trying to re-find this fix. It was so simple (uninstall WPS Office) that I didn't write it down 2 years ago when I first resolved it. Then after a recent Windows 10 update that corrupted my Laptop's audio, mic and camera and needed a system reset and windows re-installation as well as reinstalling and re-configuring so many other tools I use (wasting another day+ thanks to Microsoft), I got stuck again. I originally thought it was caused by my SIPMath excel add-in, but eventually realized it was all add-ins. WPS Office should come with an option and a warning, "Do not install if you plan on using Excel!"

I am thankful for this tip. After I deleted the "WPS Office" that comes installed on ASUS laptops, I was able to use solver finally. Thanks again


This error "Cannot run the macro 'SOLVER.XLAM!GetGroupLapel'. The macro may not be available in this workbook or all macros may be disabled." was a nightmare!

Thank you so much @DavidDodd888 You a life-saver. I uninstall the WPS Office that came with my Asus laptop and the solver has been working amazingly. 


I own an Asus laptop and have been trying to use solver but I'm getting the error Cannot run the macro 'SOLVER.XLAM!MainEx' and Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'. I tried uninstalling and reinstalling office 2016 and then even installed 2019 but the same error occurs. Also i don't have WPS office on my laptop. Please help as I need to work with the solver on an immediate basis.

Any help from anyone would be highly appreciated.


Try installing the 32bit version of Office365. The issue seems to be related to the Solver32.DLL   I just encountered the same problem and installing the 32bit version resolved it

@GR80004 This worked for me! Try installing office 32 bit instead of 64 bit. Couldn't get 64bit to work no matter what i tried. Now 32bit is working fine

@DavidDodd888 You are the man, ive had this problem for like 2 years and you solved it. Thanks!

uninstalling WPS Office did solve the SOLVER problem. 64bit of Office version is not the problem.
国内的朋友们 如果要用规划求解请卸载WPS吧 确实干扰了
Thank you so much, best solution