SOLVED

Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'.

%3CLINGO-SUB%20id%3D%22lingo-sub-220417%22%20slang%3D%22en-US%22%3ECannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-220417%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20need%20to%20use%20the%20solver%20add-in%20for%20my%20studies.%20However%2C%20Every%20time%20I%20try%20to%20use%20it%20I%20get%20an%20error%3A%20%22Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%20The%20macro%20may%20not%20be%20avaliable%20in%20this%20workbook%20or%20all%20macros%20may%20be%20disabled.%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EEven%20if%26nbsp%3BI%20uninstalled%20Office%20products%20on%20my%20PC%2C%20the%20error%20was%20not%20solved.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20will%20be%20glad%20if%20you%20solve%20this%20problem.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%2C%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-220417%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-254208%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-254208%22%20slang%3D%22en-US%22%3E%3CP%3EHope%20that%20the%26nbsp%3Bfollowing%20link%20is%20helpful%20to%20you.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2F0a45c5a5-541f-4447-8053-eb7b4d442cfa%2Fexcel-2016-solver-error-message-windows-10%3Fforum%3Dexcel%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2F0a45c5a5-541f-4447-8053-eb7b4d442cfa%2Fexcel-2016-solver-error-message-windows-10%3Fforum%3Dexcel%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-254207%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-254207%22%20slang%3D%22en-US%22%3EThank%20you%20for%20trying%20to%20solve%20it%2C%20but%20it%20the%20error%20actually%20appear%20after%20add-in%20is%20enabled%20(through%20options%20like%20you%20say)%20and%20after%20you%20try%20to%20use%20it%20(press%20on%20solvers%20button)%20it%20shows%20an%20error%20%22Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%20The%20macro%20may%20not%20be%20available%20in%20this%20workbook%20or%20all%20macros%20may%20be%20disabled.%22%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-253946%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-253946%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20not%20used%20to%20use%20%22Solver.xlam%22%20but%20it%20is%20related%20to%20add-ins.%20You%20may%20go%20to%20Option%20--%26gt%3B%20Add-Ins%20to%20see%20if%20it%20is%20enabled%20or%20not.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-253875%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-253875%22%20slang%3D%22en-US%22%3EHas%20anyone%20helped%20to%20solve%20this%20issue%3F%3CBR%20%2F%3EMy%20exams%20are%20approaching%20and%20I%20still%20haven't%20solved%20this%20issue%2C%20have%20tried%20to%20re-install%204%20times%20already%2C%20nothing%20is%20changing.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-853155%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-853155%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20recently%20encountered%20a%20similar%20issue%20with%20Solver.%20Uninstalling%20and%20installing%20office%20365%20did%20not%20work.%20The%20issue%20I%20think%20was%20caused%20by%2032bit%20vs%2064bit%20incompatibility%20yet%20when%20I%20checked%20office%2C%20windows%2C%20and%20my%20laptop%20they%20were%20all%2064bit.%20Then%20once%2C%20when%20I%20was%20uninstalling%20MS%20office%20I%20noticed%20that%20there%20was%20another%20office%20app%20that%20came%20with%20my%20laptop%20called%20%22WPS%20Office%22%20which%20is%20freeware%20shipped%20with%20Asus.%20Since%20I%20was%20not%20using%20it%2C%20I%20decided%20to%20uninstall%20it.%20And%20voila%20that%20made%20solver%20work%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-868367%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-868367%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F408084%22%20target%3D%22_blank%22%3E%40DavidDodd888%3C%2FA%3E%26nbsp%3BThank%20you%20so%20much%2C%20after%20unistalling%20%22WPS%20office%22%20(that%20I%20never%20installed%2C%20because%20it%20came%20with%20my%20windows)%2C%20Solver%20is%20working%20again!!!%3CBR%20%2F%3EI%20had%20installed%203%20different%20versions%20of%20office%20and%20then%20I%20decided%20to%20reset%20my%20windows.%20Nothing%20worked.%3CBR%20%2F%3EUnistalling%20WPS%20office%20is%20the%20solution%20!!!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1043394%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1043394%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F408084%22%20target%3D%22_blank%22%3E%40DavidDodd888%3C%2FA%3Ethank%20you%20so%20much%20your%20the%20best!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1094804%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1094804%22%20slang%3D%22en-US%22%3EYou%20my%20friend%20have%20saved%20my%20life!%20Thank%20you%20for%20this!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1210527%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1210527%22%20slang%3D%22en-US%22%3EI've%20wasted%20a%20day%20trying%20to%20re-find%20this%20fix.%20It%20was%20so%20simple%20(uninstall%20WPS%20Office)%20that%20I%20didn't%20write%20it%20down%202%20years%20ago%20when%20I%20first%20resolved%20it.%20Then%20after%20a%20recent%20Windows%2010%20update%20that%20corrupted%20my%20Laptop's%20audio%2C%20mic%20and%20camera%20and%20needed%20a%20system%20reset%20and%20windows%20re-installation%20as%20well%20as%20reinstalling%20and%20re-configuring%20so%20many%20other%20tools%20I%20use%20(wasting%20another%20day%2B%20thanks%20to%20Microsoft)%2C%20I%20got%20stuck%20again.%20I%20originally%20thought%20it%20was%20caused%20by%20my%20SIPMath%20excel%20add-in%2C%20but%20eventually%20realized%20it%20was%20all%20add-ins.%20WPS%20Office%20should%20come%20with%20an%20option%20and%20a%20warning%2C%20%22Do%20not%20install%20if%20you%20plan%20on%20using%20Excel!%22%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1231490%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1231490%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20thankful%20for%20this%20tip.%20After%20I%20deleted%20the%20%22WPS%20Office%22%20that%20comes%20installed%20on%20ASUS%20laptops%2C%20I%20was%20able%20to%20use%20solver%20finally.%20Thanks%20again%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1258505%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1258505%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20error%20%22Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetGroupLapel'.%20The%20macro%20may%20not%20be%20available%20in%20this%20workbook%20or%20all%20macros%20may%20be%20disabled.%22%20was%20a%20nightmare!%3C%2FP%3E%3CP%3EThank%20you%20so%20much%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F408084%22%20target%3D%22_blank%22%3E%40DavidDodd888%3C%2FA%3E%26nbsp%3BYou%20a%20life-saver.%20I%20uninstall%20the%20WPS%20Office%20that%20came%20with%20my%20Asus%20laptop%20and%20the%20solver%20has%20been%20working%20amazingly.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1392087%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1392087%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3EI%20own%20an%20Asus%20laptop%20and%20have%20been%20trying%20to%20use%20solver%20but%20I'm%20getting%20the%20error%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!MainEx'%20and%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%20I%20tried%20uninstalling%20and%20reinstalling%20office%202016%20and%20then%20even%20installed%202019%20but%20the%20same%20error%20occurs.%20Also%20i%20don't%20have%20WPS%20office%20on%20my%20laptop.%20Please%20help%20as%20I%20need%20to%20work%20with%20the%20solver%20on%20an%20immediate%20basis.%3CBR%20%2F%3E%3CBR%20%2F%3EAny%20help%20from%20anyone%20would%20be%20highly%20appreciated.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1477977%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.XLAM!GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1477977%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F668868%22%20target%3D%22_blank%22%3E%40Rahul_Dubey%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETry%20installing%20the%2032bit%20version%20of%20Office365.%20The%20issue%20seems%20to%20be%20related%20to%20the%20Solver32.DLL%26nbsp%3B%20%26nbsp%3BI%20just%20encountered%20the%20same%20problem%20and%20installing%20the%2032bit%20version%20resolved%20it%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1585327%22%20slang%3D%22es-ES%22%3ERe%3A%20Cannot%20run%20the%20macro%20'SOLVER.%20XLAM!%20GetSolverLabel'.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1585327%22%20slang%3D%22es-ES%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169681%22%20target%3D%22_blank%22%3E%40muhammet%20atasever%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

Hi,

 

I need to use the solver add-in for my studies. However, Every time I try to use it I get an error: "Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'. The macro may not be avaliable in this workbook or all macros may be disabled."

 

Even if I uninstalled Office products on my PC, the error was not solved.

 

I will be glad if you solve this problem.

 

Thanks,

14 Replies
Highlighted
Has anyone helped to solve this issue?
My exams are approaching and I still haven't solved this issue, have tried to re-install 4 times already, nothing is changing.
Highlighted

I am not used to use "Solver.xlam" but it is related to add-ins. You may go to Option --> Add-Ins to see if it is enabled or not. 

Highlighted
Thank you for trying to solve it, but it the error actually appear after add-in is enabled (through options like you say) and after you try to use it (press on solvers button) it shows an error "Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'. The macro may not be available in this workbook or all macros may be disabled."
Highlighted
Highlighted
Best Response confirmed by cuong (Microsoft)
Solution

I've recently encountered a similar issue with Solver. Uninstalling and installing office 365 did not work. The issue I think was caused by 32bit vs 64bit incompatibility yet when I checked office, windows, and my laptop they were all 64bit. Then once, when I was uninstalling MS office I noticed that there was another office app that came with my laptop called "WPS Office" which is freeware shipped with Asus. Since I was not using it, I decided to uninstall it. And voila that made solver work again.

Highlighted

@DavidDodd888 Thank you so much, after unistalling "WPS office" (that I never installed, because it came with my windows), Solver is working again!!!
I had installed 3 different versions of office and then I decided to reset my windows. Nothing worked.
Unistalling WPS office is the solution !!!!

Highlighted

@DavidDodd888thank you so much your the best!

Highlighted
You my friend have saved my life! Thank you for this!
Highlighted
I've wasted a day trying to re-find this fix. It was so simple (uninstall WPS Office) that I didn't write it down 2 years ago when I first resolved it. Then after a recent Windows 10 update that corrupted my Laptop's audio, mic and camera and needed a system reset and windows re-installation as well as reinstalling and re-configuring so many other tools I use (wasting another day+ thanks to Microsoft), I got stuck again. I originally thought it was caused by my SIPMath excel add-in, but eventually realized it was all add-ins. WPS Office should come with an option and a warning, "Do not install if you plan on using Excel!"
Highlighted

I am thankful for this tip. After I deleted the "WPS Office" that comes installed on ASUS laptops, I was able to use solver finally. Thanks again

Highlighted

 

This error "Cannot run the macro 'SOLVER.XLAM!GetGroupLapel'. The macro may not be available in this workbook or all macros may be disabled." was a nightmare!

Thank you so much @DavidDodd888 You a life-saver. I uninstall the WPS Office that came with my Asus laptop and the solver has been working amazingly. 

 

Highlighted
Hi,
I own an Asus laptop and have been trying to use solver but I'm getting the error Cannot run the macro 'SOLVER.XLAM!MainEx' and Cannot run the macro 'SOLVER.XLAM!GetSolverLabel'. I tried uninstalling and reinstalling office 2016 and then even installed 2019 but the same error occurs. Also i don't have WPS office on my laptop. Please help as I need to work with the solver on an immediate basis.

Any help from anyone would be highly appreciated.
Highlighted

@Rahul_Dubey 

Try installing the 32bit version of Office365. The issue seems to be related to the Solver32.DLL   I just encountered the same problem and installing the 32bit version resolved it

Highlighted