Troubleshooting with Edge Chromium

%3CLINGO-SUB%20id%3D%22lingo-sub-1203497%22%20slang%3D%22en-US%22%3ETroubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1203497%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20recently%20installed%20the%20release%20version%20of%20Microsoft%20Edge%20Chromium%20on%202%20systems%20running%20Windows%2010%20Pro%20with%20all%20latest%20updates%20installed.%20I%20have%20had%20a%20few%20issues%20which%20I%20have%20reported%20via%20the%20normal%20feedback%20link%20but%20I%20have%20one%20problem%20that%20I%20cannot%20get%20to%20the%20bottom%20of.%3C%2FP%3E%3CP%3EI%20recently%20received%20a%20free%20one%20year%20subscription%20to%20Apple%20TV%2B%20(because%20I%20bought%20a%20new%20iPad).%20I%20want%20to%20be%20able%20to%20access%20by%20Apple%20TV%2B%20account%20from%20the%202%20Windows%20PC's.%3C%2FP%3E%3CP%3EUsing%20the%20new%20Edge%20Browser%20I%20went%20to%20the%20tv.apple.com%20website%20and%20logged%20in%20with%20my%20Apple%20credentials.%20Everything%20works%20fine%20on%20one%20of%20the%20PC's%20but%20on%20the%20other%20when%20I%20try%20to%20play%20a%20program%20all%20I%20get%20is%20a%20black%20screen%20with%20the%20play%20controls%20along%20the%20bottom.%20Pressing%20the%20play%20button%20does%20nothing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBoth%20PC's%20are%20the%20same%20make%20and%20model%20(Azulle%20Byte%203)%20with%20same%20specs%20for%20memory%20and%20disk.%20I%20have%20compared%20graphics%20system%20settings%20and%20Edge%20browser%20settings%20on%20both%20of%20them%20and%20cannot%20find%20any%20differences.%20Graphics%20driver%20versions%20were%20the%20same%20on%20both%20but%20I%20did%20find%20that%20Intel%20had%20recently%20released%20a%20new%20driver%20so%20I%20installed%20that%20on%20the%20PC%20that%20doesn't%20work%20but%20it%20made%20no%20difference.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CU%3EAll%20other%20streaming%20sites%20work%20fine%20on%20both%20PC's%20using%20Edge%3C%2FU%3E%20and%20Apple%20TV%2B%20works%20using%20Firefox%20on%20both%20systems.%26nbsp%3B%20It%20just%20won't%20work%20on%20one%20of%20them%20using%20Edge.%3C%2FP%3E%3CP%3EI%20tried%20uninstalling%20and%20reinstalling%20Edge%20Chromium%20on%20the%20faulty%20system%20but%20that%20didn't%20make%20a%20difference%20either.%3C%2FP%3E%3CP%3EThe%20only%20thing%20that%20I%20did%20different%20on%20the%20%22faulty%22%20system%20was%20that%20initially%20I%26nbsp%3B%20installed%20Apple%20TV%2B%20via%20Edge%20as%20a%20PWA%20App.%20It%20behaved%20exactly%20as%20I%20described%20above%20resulting%20in%20a%20black%20screen%20with%20just%20the%20inoperative%20controls.%20I%20then%20tried%20to%20access%20the%20site%20through%20the%20browser%20and%20saw%20the%20same%20behavior%20so%20using%20Uninstall%20from%20the%20settings%20pages%20I%20uninstalled%20the%20PWA%20App%20but%20accessing%20through%20the%20browser%20still%20didn't%20work.%20I%20subsequently%20uninstalled%20the%20browser%20and%20reinstalled%20it%2C%20as%20I%20mentioned%20above%2C%20but%20still%20no%20joy.%3C%2FP%3E%3CP%3EI'm%20at%20a%20loss%20as%20to%20what%20to%20try%20next%2C%20so%20I%20wondered%20if%20anyone%20in%20this%20community%20had%20any%20ideas%20for%20troubleshooting%20the%20problem%20further.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20for%20being%20so%20long%20winded.%3C%2FP%3E%3CP%3EMike%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1203512%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1203512%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570905%22%20target%3D%22_blank%22%3E%40MikeL99%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20suggestion%20you%20can%20try%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGo%20to%3A%20%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%3C%2FA%3E%3C%2FP%3E%3CP%3EFind%20this%20flag%20and%20%3CSTRONG%3Eenable%3C%2FSTRONG%3E%20%3CSTRONG%3Eit%3C%2FSTRONG%3E%3A%3C%2FP%3E%3CP%3EWidevine%20DRM%3C%2FP%3E%3CP%3Eand%20find%20this%20flag%20and%20%3CSTRONG%3Edisable%20it%3C%2FSTRONG%3E%3A%3C%2FP%3E%3CP%3EPlayReady%20DRM%20for%20Windows%2010%3C%2FP%3E%3CP%3Erestart%20Edge%20and%20try%20your%20Apple%20TV%20website%20again%20see%20if%20you%20are%20still%20getting%20black%20screen.%3C%2FP%3E%3CP%3Eif%20it%20doesn't%20work%2C%20try%20the%20other%20way%20around.%20hope%20it%20helps%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1203667%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1203667%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%20Thanks%20for%20the%20suggestion%20but%20it%20didn't%20work.%20When%20I%20enabled%20Widevine%20DRM%20and%20disabled%20PlayReady%20DRM%20the%20behavior%20was%20the%20same%20as%20before.%20When%20I%20reversed%20them%20the%20result%20was%20worse%20-%20all%20I%20got%20was%20a%20black%20screen%20with%20a%20single%20white%20line.%20The%20title%20and%20play%20controls%20were%20not%20shown.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1212607%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1212607%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570905%22%20target%3D%22_blank%22%3E%40MikeL99%3C%2FA%3E%26nbsp%3BThank%20you%20for%20taking%20the%20time%20to%20reach%20out.%20I'm%20looping%20in%20our%20product%20team%2C%20but%20in%20the%20meantime%2C%20can%20you%20please%20submit%20feedback%20and%20diagnostic%20data%20through%20the%20browser%3F%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)Project%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1215894%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1215894%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484598%22%20target%3D%22_blank%22%3E%40fawkes%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20for%20delay%20in%20responding.%20Can%20you%20tell%20me%20what%20kind%20of%20diagnostic%20data%20you%20need%20and%20how%20I%20go%20about%20capturing%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMike%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1215947%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1215947%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22lia-spoiler-container%22%3E%3CA%20class%3D%22lia-spoiler-link%22%20href%3D%22%23%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%20target%3D%22_blank%22%3ESpoiler%3C%2FA%3E%3CNOSCRIPT%3E(Highlight%20to%20read)%3C%2FNOSCRIPT%3E%3CDIV%20class%3D%22lia-spoiler-border%22%3E%3CDIV%20class%3D%22lia-spoiler-content%22%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570905%22%20target%3D%22_blank%22%3E%40MikeL99%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484598%22%20target%3D%22_blank%22%3E%40fawkes%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20for%20delay%20in%20responding.%20Can%20you%20tell%20me%20what%20kind%20of%20diagnostic%20data%20you%20need%20and%20how%20I%20go%20about%20capturing%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMike%3C%2FP%3E%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%3C%2FDIV%3E%3CNOSCRIPT%3E%3CDIV%20class%3D%22lia-spoiler-noscript-container%22%3E%3CDIV%20class%3D%22lia-spoiler-noscript-content%22%3E%26nbsp%3Bwrote%3A%26nbsp%3BSorry%20for%20delay%20in%20responding.%20Can%20you%20tell%20me%20what%20kind%20of%20diagnostic%20data%20you%20need%20and%20how%20I%20go%20about%20capturing%20it.%26nbsp%3BMike%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FNOSCRIPT%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22ss.png%22%20style%3D%22width%3A%20402px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F175770iBA97819F3D687794%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22ss.png%22%20alt%3D%22ss.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22sss.png%22%20style%3D%22width%3A%20902px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F175771i26AF0B887CF7FC19%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22sss.png%22%20alt%3D%22sss.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1221151%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1221151%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570905%22%20target%3D%22_blank%22%3E%40MikeL99%3C%2FA%3E%26nbsp%3BI'm%20happy%20to%20let%20you%20know%20that%20this%20is%20on%20the%20product%20team's%20radar%2C%20and%20while%20it%20might%20take%20a%20little%20time%20to%20roll%20out%2C%20a%20fix%20is%20in%20the%20works!%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)Project%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1223720%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1223720%22%20slang%3D%22en-US%22%3EThank%20you.%20Can%20you%20give%20me%20any%20indication%20of%20what%20is%20causing%20the%20problem.%20It's%20weird%20that%20it%20works%20on%20one%20PC%20but%20not%20on%20another%20identical%20one.%3CBR%20%2F%3EMike%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1223774%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1223774%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570905%22%20target%3D%22_blank%22%3E%40MikeL99%3C%2FA%3E%26nbsp%3BSure%20thing%2C%20happy%20to%20help!%20I%20am%20not%20aware%20of%20the%20exact%20mechanics%20that%20the%20new%20code%20is%20targeting%2C%20but%20I%20will%20let%20you%20know%20if%20I%20find%20out.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)Project%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1337571%22%20slang%3D%22en-US%22%3ERe%3A%20Troubleshooting%20with%20Edge%20Chromium%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1337571%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570905%22%20target%3D%22_blank%22%3E%40MikeL99%3C%2FA%3E%26nbsp%3BDid%20you%20happen%20to%20install%20this%20app%20named%20%22HEVC%20Video%20Extensions%20from%20Device%20Manufacturer%22%20from%20Microsoft%20Store%20(%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fp%2Fhevc-video-extensions-from-device-manufacturer%2F9n4wgh0z6vhq%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Elink%3C%2FA%3E)%3F%20I%20uninstalled%20it%20and%20Apple%20TV%2B%20became%20functional%20afterwards.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I have recently installed the release version of Microsoft Edge Chromium on 2 systems running Windows 10 Pro with all latest updates installed. I have had a few issues which I have reported via the normal feedback link but I have one problem that I cannot get to the bottom of.

I recently received a free one year subscription to Apple TV+ (because I bought a new iPad). I want to be able to access by Apple TV+ account from the 2 Windows PC's.

Using the new Edge Browser I went to the tv.apple.com website and logged in with my Apple credentials. Everything works fine on one of the PC's but on the other when I try to play a program all I get is a black screen with the play controls along the bottom. Pressing the play button does nothing.

 

Both PC's are the same make and model (Azulle Byte 3) with same specs for memory and disk. I have compared graphics system settings and Edge browser settings on both of them and cannot find any differences. Graphics driver versions were the same on both but I did find that Intel had recently released a new driver so I installed that on the PC that doesn't work but it made no difference.

 

All other streaming sites work fine on both PC's using Edge and Apple TV+ works using Firefox on both systems.  It just won't work on one of them using Edge.

I tried uninstalling and reinstalling Edge Chromium on the faulty system but that didn't make a difference either.

The only thing that I did different on the "faulty" system was that initially I  installed Apple TV+ via Edge as a PWA App. It behaved exactly as I described above resulting in a black screen with just the inoperative controls. I then tried to access the site through the browser and saw the same behavior so using Uninstall from the settings pages I uninstalled the PWA App but accessing through the browser still didn't work. I subsequently uninstalled the browser and reinstalled it, as I mentioned above, but still no joy.

I'm at a loss as to what to try next, so I wondered if anyone in this community had any ideas for troubleshooting the problem further.

 

Sorry for being so long winded.

Mike

9 Replies
Highlighted

Hi@MikeL99 

I have a suggestion you can try

 

Go to: edge://flags/

Find this flag and enable it:

Widevine DRM

and find this flag and disable it:

PlayReady DRM for Windows 10

restart Edge and try your Apple TV website again see if you are still getting black screen.

if it doesn't work, try the other way around. hope it helps

Highlighted

@HotCakeX  Thanks for the suggestion but it didn't work. When I enabled Widevine DRM and disabled PlayReady DRM the behavior was the same as before. When I reversed them the result was worse - all I got was a black screen with a single white line. The title and play controls were not shown.

Highlighted

@MikeL99 Thank you for taking the time to reach out. I'm looping in our product team, but in the meantime, can you please submit feedback and diagnostic data through the browser? 

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted

@fawkes 

Sorry for delay in responding. Can you tell me what kind of diagnostic data you need and how I go about capturing it.

 

Mike

Highlighted
Spoiler

@MikeL99 wrote:

@fawkes 

Sorry for delay in responding. Can you tell me what kind of diagnostic data you need and how I go about capturing it.

 

Mike


ss.png

 

sss.png

 

Highlighted

@MikeL99 I'm happy to let you know that this is on the product team's radar, and while it might take a little time to roll out, a fix is in the works!

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted
Thank you. Can you give me any indication of what is causing the problem. It's weird that it works on one PC but not on another identical one.
Mike
Highlighted

@MikeL99 Sure thing, happy to help! I am not aware of the exact mechanics that the new code is targeting, but I will let you know if I find out.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted

@MikeL99 Did you happen to install this app named "HEVC Video Extensions from Device Manufacturer" from Microsoft Store (link)? I uninstalled it and Apple TV+ became functional afterwards.