SOLVED
Home

Remove teams message from modern sites

%3CLINGO-SUB%20id%3D%22lingo-sub-758553%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-758553%22%20slang%3D%22en-US%22%3ESee%20%3CA%20href%3D%22https%3A%2F%2Fthesharepointfarm.com%2F2019%2F04%2Fdisable-teams-creation-prompt-in-spo%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fthesharepointfarm.com%2F2019%2F04%2Fdisable-teams-creation-prompt-in-spo%2F%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-758735%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-758735%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%26nbsp%3B%20Thanks!!%20I'll%20try%20it%20right%20away.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-760267%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-760267%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%26nbsp%3Bseems%20like%20it%20didn't%20work%20out.%20Runned%20the%20script%20yeterday%20without%20problems%20and%20gave%20it%20some%20time%20to%20refresh%20and%20nothing%20happened.%20I've%20been%20waiting%20some%20hours%20to%20see%20if%20this%20was%20one%20of%20those%20cases%20the%20tenant%20takes%20hours%20to%20refresh%20but%20with%20no%20luck%20so%20far.%20Thanks%20any%20way%20for%20your%20help%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-762079%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-762079%22%20slang%3D%22en-US%22%3EI'm%20seeing%20the%20same%20issue%20-%20I'll%20see%20if%20I%20can%20work%20out%20why%20it%20isn't%20working.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-762197%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-762197%22%20slang%3D%22en-US%22%3Eworked%20it%20out%20-%20the%20script%20was%20missing%20a%20line.%3CBR%20%2F%3E%3CBR%20%2F%3EAbove%20the%20'Set-PnPropertyBagValue'%20line%2C%20add%20this%20line%3A%3CBR%20%2F%3E%3CBR%20%2F%3EConnect-PnPOnline%20-Url%20%24web%20-SPOManagementShell%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-762256%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-762256%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%26nbsp%3Bthat%20worked%20like%20a%20charm%20and%20instantly!%20Too%20bad%20yesterday%20I%20thought%20this%20change%20wasn't%20been%20done%20on%20the%20web%20and%20I%20didn''t%20realize%20the%20missing%20connection%20to%20the%20web%20as%20it%26nbsp%3B%20is%20supposed%20to%20be%20done%20on%20a%20site%20collection%20by%20site%20collectio%20basis.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-758520%22%20slang%3D%22en-US%22%3ERemove%20teams%20message%20from%20modern%20sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-758520%22%20slang%3D%22en-US%22%3E%3CP%3EWell%2C%20first%20of%20all%2C%20hi%20all%2C%20this%20is%20my%20first%20post%20on%20the%20tech%20community%20and%20I%20hope%20you%20guys%20can%20help%20me%20out.%20I%20have%20this%20client%20who%20is%20willing%20to%20remove%20or%20disable%20the%20message%20displayed%20when%20you%20access%20to%20modern%20sites%20in%20SharePoint%20Online.%20I'm%20talking%20about%20the%20message%20that%20prompts%20you%20to%20create%20a%20Microsoft%20teams.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20checked%20the%20Set-SPOTenant%20options%20and%20none%20of%20them%20seems%20to%20tackle%20this%20need.%26nbsp%3BIs%20is%20even%20possible%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBTW%2C%20the%20client%20is%20quite%20zealot%20against%20custom%20developments%2C%20so%20spfx%20extensions%20are%20a%20no%20go%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-758520%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Gonzix
Occasional Contributor

Well, first of all, hi all, this is my first post on the tech community and I hope you guys can help me out. I have this client who is willing to remove or disable the message displayed when you access to modern sites in SharePoint Online. I'm talking about the message that prompts you to create a Microsoft teams.

 

I have checked the Set-SPOTenant options and none of them seems to tackle this need. Is is even possible? 

 

BTW, the client is quite zealot against custom developments, so spfx extensions are a no go

6 Replies

@Rob Ellis  Thanks!! I'll try it right away. 

@Rob Ellis seems like it didn't work out. Runned the script yeterday without problems and gave it some time to refresh and nothing happened. I've been waiting some hours to see if this was one of those cases the tenant takes hours to refresh but with no luck so far. Thanks any way for your help

I'm seeing the same issue - I'll see if I can work out why it isn't working.
Solution
worked it out - the script was missing a line.

Above the 'Set-PnPropertyBagValue' line, add this line:

Connect-PnPOnline -Url $web -SPOManagementShell
Highlighted

@Rob Ellis that worked like a charm and instantly! Too bad yesterday I thought this change wasn't been done on the web and I didn''t realize the missing connection to the web as it  is supposed to be done on a site collection by site collectio basis.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
16 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
11 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Early preview of Microsoft Edge group policies
Sean Lyndersay in Discussions on
65 Replies