Windows 11 Task Bar Empty

Occasional Contributor

Ok, so almost every time I boot up windows 11, my task bar shows, but only the tray icon arrow shows/works.

 

The rest of the task bar doesn't load/appear. If I wait for maybe half hour and kill exporer.exe and restart it, it starts working again.

 

Now I don't always have to wait this long, but sometimes it takes ages.

Once in a while it'll work fine, but that's rare.

32 Replies
I have the same problem, but I can't load taskbar items at all even after half hour. I restart eplorer, run sfc scan, remove the latest quality update and doesn't work at all. I can't open settings too, and my desktop right click menu bring back to old version.
please help me. I use the latest update (build 22000.168)
I'm also having the exact same problem, have you found a solution to this?
The only thing I can do to make it work again is to reinstall 22000.100.

@Denzic Unfortunately not :(

I've reported the bug via the feedback software, but nothing back.

I really do hope this gets fixed, it's a pretty major bug.

I am having this exact problem. Even after restarting the pc nothing will work. How did you resolve this??
Yeah, it's so weird I've had this problem for more than a week, but I can't find anyone else who has this problem.
Unfortunately, I haven't.
Reinstall the previous version is the only workaround I found working.
The one I installed is 22000.100
Thanks Andrej, but I have tried this already and it's not working for me.
I'll give this a go later :crossed_fingers:
https://techcommunity.microsoft.com/t5/windows-insider-program/windows-11-dev-build-missing-taskbar/...
This discussion is helped by the setting - changing time with forward date is worth checking.
Ok so this issue has popped up again after the last update, but I can't seem to get the task bar to show up at all, no matter what I do now.
Update on this, it got to the point where I couldn't use the computer anymore, so I've done a reset from boot, this fixed the issue. I'm wondering if this is related to upgrading from windows 10 with possible straggling files and or old software / drivers which could be causing this. But a proper fresh install did get rid of the problem.

I've also found that the prescribed fix doesn't seem to do anything. My solution is restart Windows Explorer. Temporary, and sometimes results in losing all of my taskbar entries in the quick menu, but it allows me to work.

So I’ve ran into this issue as well and I’ve done the cmd thing and still didn’t work… I can reboot or anything…
Had a problem with my HP. I updated it a week ago and now the taskbar is bugged, and my laptop was factory reset, leading me to believe it´s the update´s fault. Anyone knows what I can do? without access to Settings I can´t restore a previous version.
Hi.
Please is a shortcut that opens the settings ( Windows + I ) - this should open access to the system settings

@Andrzej1  W + R & W+X are not working, I think I might have to access through recovery mode.

A hard reset (hold down the power button for 10 seconds)
restart - you can repeat it .
the system should automatically repair itself

@waptaincaffles 

 

I'm on the Insiders Build and this is something that had been giving me some trouble for a while.  First, I had been pointed to the IrisService but that was a dead-end, and then I also been told to restart the WSearch service which may have worked but wasn't consistent.

 

Finally, someone mentioned trying to restart explorer, so I decided to give that a try.  You could probably get this accomplished with cmd but I tend to use PowerShell more.

 

Get-process -Name explorer | Stop-Process

 

This killed the Explorer process and the Taskbar immediately came back and is working fine now.  I'll see if I can try to reproduce again to verify, but this is a good start.